Install USB DAC software

I have been trying to install the driver for the sound blaster play 3 dac
through wine, but the wizard can't detect the device and won't complete installation.
Screenshot from 2022-06-29 23-13-39

Screenshot from 2022-06-29 23-13-47

Here is the link to the webpage download: creative.com/SBP3

It is entirely possible that no one has done the coding to get it work with Linux.Maybe something changed because that information is 3 years ago. i saw on your link and there isn't information it will be working. In operating systems we know apple products for apple products windows products for windows products. Linux products for exist drivers products.
Here is propably solution.
I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

FYI: There are some really nice graphical (GUI) programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager (SPM) that you can install and use. You may notice more options using QasMixer. Recommend installing "pulse audio volume control" as well.

Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" and make it fullscreen, on the right side you will have mixer devices where you can control your system sound. If you do not see the mixer devices, hit "F6". The mixer item "sysdefault" will show all installed sound card devices, and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. There are also various other check boxes below that you can use, and depending upon your sound card(s) that sometimes includes headphone checkboxes and or sliders as well, like "Headphone Jack Sense".

The applications included are:

  • qasconfig - browser for the alsa configuration tree
  • qashctl - mixer for alsa's high level control interface
  • qasmixer - desktop mixer with features similar to alsamixer

Qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a sytem tray icon with basic mixer functionality.

Hope this helps ...
That's great that all you had to do is select the sound output device.

Your system will default to a sound device, now whether that would be your Sound Blaster would depend on if you have more than one sound device in your system thus my request for more information.

If you also check out the QasMixer, you may see some good settings to tweak your sound card.

Good YouTube video here:

Doesn't this indicate that device should work on Ubuntu therefore ZorinOS.

Has the OP looked for driver in Zorin/Software?

Based on that youtube video, the man requirement is to ensure that pulse audio volume control be installed. (I hate pulse audio with a vengeance!)

I prefered pipewire on Zorin.

Here is what shows when inxi -fxzd and isusb is typed in the terminal.

inxi -Fxzd

Command 'inxi' not found, but can be installed with:

sudo apt install inxi

Isusb

Command 'Isusb' not found, did you mean:

command 'lsusb' from deb usbutils (1:012-2)

Try: sudo apt install

I use both pulseaudio and qasmixer on my system. I wanted to install the driver to see if there are any other effects or options that can be modified.

Inxi is a good tool to have. It is one of my high priority items that I install on a fresh OS installation.

sudo apt install inxi

Once installed:

inxi -Fxzd

This will relay informatice hardware specs about your machine.

1 Like

I saw some post on mint forum and this usb dac working.

Here is the audio information from inxi -Fxzd

Audio:
Device-1: Intel vendor: Realtek driver: snd_hda_intel v: kernel
bus ID: 00:0e.0
Device-2: Creative Sound Blaster Play! 3 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2
Sound Server: ALSA v: k5.13.0-51-generic

While researching this a bit, I came across this post which put a smile on my face:

I'll try a reboot.
__
That solved it. sometimes it's better that if you see hoof prints, don't go looking for zebras.

= "Have you tried turning it off and on again?"

It Crowd Maurice Moss GIF

Tried rebooting with terminal, same problem occurs when installing software.

Just had another look at your audio devices post. I think what is happening is you are getting conflict between Intel and the DAC. You need to Blacklist the Intel device so that the DAC becomes the only device for sound output. Follow my guide here:

I remember sometimes have problems with volume voice not hearing or my system don't seeing that. After restart everything working correctly or just use settings. That is true pulse audio project died and people moved from this project to pipewire?

I should clarify that I am getting sound through the USB DAC.

Is there a command to undo "blacklist snd_hda_intel" if needed?

Ok. My mistakes. Sometimes the problem isn't with Linux Zorin but pins port usb. They could don't touch your pins from your dac and laptop or what you have.
Here working
https://forums.linuxmint.com/viewtopic.php?t=270619