Install Zorin 16 Pro hangs at "Updates and other software"

I have a Dell Optiplex 7020 with 16GB RAM and 512GB SSD running Windows 10 Pro, pre-installed on a refurbished machine from Amazon. I want to install Zorin 16 Pro "alongside" it, so I can boot to either one, getting lots of experience with Zorin before cutting the cord and kissing Windows goodbye. Initially, I burned the 16Pro iso file to a dual-layer DVD, but in order to boot the DVD, I set the BIOS to "legacy" boot, with the optical drive first in boot order. That worked, but the Zorin install said it couldn't find another operating system, so could not do the install "beside" the Windows 10 installation. Windows 10 is in a GPT partition on the SSD, booted with UEFI.

So I used Macrium Reflect Free edition to make an image of the SSD onto a flash drive, in case Zorin messed up the drive.

Thinking that doing a legacy boot of the Zorin DVD caused it not to find the Windows 10 partitions, I then used BalenaEtcher to burn the Zorin 16 Pro iso file to a flash drive, set the BIOS to enable boot from USB, and set it back to UEFI boot. After doing this, booting brought up the Windows boot menu, and I was able to navigate to boot from the flash drive. This worked, and I selected to install Zorin 16. I got to the "Updates and other software" screen, clicked "Continue", and that screen got as far as the fourth progress dot and just stayed there with the washing-machine cursor (for more than 2 hours) before I clicked the "Quit" button. I did this twice and got the same behavior. Here is a photo of the screen:

What can I do? I have no idea how to fix this. Are there some kind of logs I could post so someone could help me figure out what's going wrong, and fix it?

For install; it is essential that in Windows > Control Panel > Power settings you disable Fast Boot or Fast Startup - this program Locks the Hard drive, preventing access.

If dual booting with Windows, you can continue using Secure Boot (Which is enabled or disabled in the BIOS EFI settings), but I recommend going ahead and disabling it. Microsoft signed off on most Linux packages in order to allow Linux to boot, but somehow, by some magical process that mystify us all, managed to not sign off on all of them.

IF still getting stuck at that screen during install, uncheck the box to connect to net and install updates as you install.
You can easily install the updates after the install and having that on during may have troubles if the installation process interrupts the drivers for network access.

Okay, Fast Boot was enabled in Control Panel, so I disabled it and tried again. Same behavior.

Next is un-checking the two options to "download updates while installing", and "install third-party software". So far, no progress after that screen has been up for about 5 minutes. How long should I expect it to take to make progress from that screen? If that doesn't make progress within an hour or so, should I try the "Minimal installation? If that works, how do I go about installing all the things that it doesn't include?

What's next? I downloaded the 16 Pro .iso file on June 1, so it's fairly fresh. Is than a checksum I should check it against? I read somewhere that a while back there were problems using the iso file on Dell computer, but they got fixed. Anything to check in the log files?

Normally, less than 5 minutes. I would give it 15 minutes though, just for good measure.

I do not believe that this would make any difference at all, since that is not where the issue is.

Please review these tips here to check the mounting and integrity of the disk:

You also might try using the S.M.A.R.T. analyzer to check disk integrity.

Have you made space for Zorin on your SSD? You will need to shrink your C:\ partition using Disk Management. You also need to turn off advanced Power Saver Settings - In Windows 10 up, the Hard Drive is never actually turned off - it sleeps, waiting to boot up instantly. You should also turn off Fast Boot in the BIOS and enable CMS in the BIOS too.

1 Like

Ahh, I just realized there wasn't any space on the SSD to install it. I quit the install, and gparted showed 4 partitions: BOOT, Microsoft reserved, Windows, and Recovery. Their sizes added up to 476.94 GiB, the size of the SSD. I thought the install was capable of replacing another operating system, though I'm glad it didn't, since I want to install alongside Windows.

But it any event, I would have hoped the install would issue some kind of message, instead of just getting stuck forever!

Well, anyway, I went ahead and shrunk the partition holding my Windows C: drive, then tried the install again. No difference, still stuck in the same place. Quit out of the install and took a screenshot of a gparted window:

So there's quite a bit of unallocated space.

This is not a very good experience, but I'd like to get it installed, because I do like using it, and would love to get weened off of Windows. Any more ideas, either things to try, or ways to get more information about what's causing the problem?

You left it as unallocated. You need to add that as a partition, formatted to ext4. Then run the installer.

Okay, trying again with 371.09GiB unallocated, this time with downloading updates and install third-party drivers turned off. That does progress to the next screen, which says no operating system was detected.

But instead of freaking out at the default of "Erase disk and install Zorin OS", I selected "Something else" and clicked "Install Now".

That went down a different path that I didn't accurately document. As I recall,
it showed partitions on the disk, with no clear instructions on what to do. I selected the unallocated space and clicked the "+" sign, which wanted to format it as ext4, so I let it. Then it popped up an error message saying there was no place for the root file system. I took some screenshots and saved them, but ultimately they were lost as a result of the next paragraph...

I couldn't figure out anything to do at that point, so I rebooted again from the flash drive, and this time just told it to erase the disk and install Zorin 16 (knowing I had the Macrium full image to get Windows back).. This actually worked! It took some time, and I had to enter some more things, but eventually I was told to remove the installation medium and reboot. So I did as I was told, and presto, it booted up (quickly), and I started the tour. I was a little puzzled when it wanted me to login to my Google account. It was giving GNOME access and control over everything in my Google account - I don't know what that means. I have several Google accounts, what does GNOME need access for? Also wanted IMAP and SMTP accounts - I intend to install Mozilla Thunderbird, so why does GNOME need that info?? Is there a document or video that explains this kind of stuff?

I expect to continue for a while getting more familiar with using the system, and then restore from the Macrium image to put the disk back as it originally was, and start over trying to install Zorin alongside Windows. I really like the look and feel, and I expect I'll be able to find all the software I need, but getting it installed with a dual boot to Windows seems extraordinarily difficult.

This is what I said to do above....

After adding the unallocated space, then formatting it as ext4, you needed to set root as /
It is the last option at the bottom of that popup window.

Also is your system using MBR method for Windows? If so you are limited to 4 primary partitions and manufacturers usually allocate 4 primary partitions - you can't add another primary partition if that is the case so something has to go! If your Notebook has option to create recovery DVDs then do so and delete your recovery partition. (Speaking from experience with HP Mini netbook!)

Thanks! I was away from the forum for a few days - I was surprised not to get email notification of replies...

Anyway, I was possibly afflicted by the problem noted below by swarfendor437, in that was an MBR disk. Or I think it was, as I finally bit the bullet and let it erase the disk, knowing I had my flash drive with a full Macrium image to start over with. But when I went to start over, I discovered that somewhere along the line I managed to reformat that flash drive, so I have no record of it :poop:

But I had a Macrium image backup of my much larger Windows 10 Home disk on a portable USB hard drive, which was also MBR. So I restored that, booted up Windows 10, defragmented it and shrunk its C: partition to leave plenty of room for Zorin, converted it to GPT with the MBR2GPT.EXE utility, and started over. I wound up following the video Zorin OS 16 + Windows 10 Dual Boot UEFI Tutorial | Install Zorin OS Core Along With Win10 | NCX Tech - YouTube I don't know why, but instead of choosing the option to install alongside Windows, the video chooses "Something else" and creates the ext4 partition for root manually, so that's what I did. It all worked nicely, and boot resulted in a menu to choose Zorin or Windows 10. Happy as a clam now!

The default of booting Zorin when it times out is fine for me, but I need to figure out how to put Windows at the top and be the default on timeout when I get around to doing my wife's laptop.

Thanks again for the help!

You may also want to consider EasyBCD from NeoSmart Technologies so that the Windows MBR does not get affected:

inspired by