Zorin Forum

Installation error: Executing ’grub-install /dev/mmcblk0p4’ failed

Bookmarking now!

1 Like

That is very kind of you, thanks :blush:

2 Likes

LiveUSB of the grub or the OS/Installer? I tried to find a way to install the grub manually as well but didn't really get anywhere (with the terminal).
(Don't know exactly if it really wouldn't have helped or if I didn't do it right - still don't know much about that area)

If you do happen to come across one again at some point, I'd be more than willing to try.

1 Like

I have been trying... I am notoriously bad at finding things on the net...
But at the time, I did take notes (at the time, /dev/sda1 was the drive I was installing Zorin OS on). I found this in my Documents:

sudo mkdir uroot
sudo mount /dev/sda1 uroot
sudo mount -o bind /dev uroot/dev
sudo mount -o bind /sys uroot/sys
sudo mount -t proc /proc uroot/proc
sudo chroot uroot
grub-install /dev/sda
update-grub
exit
sudo umount uroot/proc
sudo umount uroot/sys
sudo umount uroot/dev
sudo umount uroot
2 Likes

If Aravisian's suggestion doesn't work you could try the Acer community. Just like yours there are several topics related to this issue.

https://community.acer.com/en/search

2 Likes

You may have to use the something else method, partition and force the bootloader to a particular partition. There have been several times in emmc, nvme and ssd drives that when the drive is selected, unless another efi bootloader is installed the system doesn't know where to put it.

Define a 500MB EFI partition, the rest for system (unless you want to use a seperate home partition) and swap partition if you want hibernate. In the dropdown after choosing something else (under the pretty partitions window) select the 500mb partition for grub. A useful guide of partitioning and installing zorin 16 is in the tutorials category.

Ctrl+s didn‘t do anything on that page. I have very few options in BIOS in general, and some of the ones I do have I don‘t seem to be able to be changed (the ones where it says [enter]).

After either one of the boot repairs or when I chose the EFI partition (about 500MB – got wiped with the Windows at first but then showed up again after another installation try?) in the “Something else“ option, and then rebooted without choosing my Live CD USB drive to try the install again, I got here:


Don‘t know if that‘s useful. I am able to write in it, but don‘t know what.

You can try typing in exit and see where that takes you. If nowhere then:
Reboot and when you get back to that screen
type in that screen

ls

this will list the drives
Look for one that looks similar to (hd0,1)/efi/boot/grub < it is the /efi/boot/grub that you are interested in finding. The (hd0,1) may be different. Or not.
When you find it, write down what it is if different from (hd0,1).
next enter each of the following lines, replacing (hd0,1) with what you wrote down earlier, if needed:

set prefix=(hd0,1)/grub

set root=(hd0,1)

insmod linux

insmod normal

normal

Try booting normally. IF it works, immediately open a terminal with ctrl+alt+t and run

sudo update-grub

1 Like

only gives me: (proc) (hd0) (hd0,gpt2) (hd0,gpt1) (hd1) (hd2)
:frowning:

Well, we definitely know that grub is not installed, then.
This issue had previously stumped @FrenchPress on her own machine where she was motivated to try her best.
This machine is also very limited in allowing User Control for modifications, which I believe are needed with your eMMC drive.
Lastly, these machines are built for Windows and some BIOS settings are accessible within Windows. Even installing over Windows with Linux can result in those settings being permanently locked in place.

It makes sense when you think about it. Companies routinely do things they are not supposed to do.
There's Money in it.
Whenever you buy a computer, you are buying Windows OS with it (excluding Made For Linux computers like System76 or StarLabs). And they want to ensure, between Microsoft and the Manufacturers, that they get their money.

2 Likes

I can barely believe I am saying this but: I DID IT!

This very thorough tutorial helped me through every step of the way: https://gist.github.com/volcanoauthors/c7c9480dc78f1ba55d589d2125db4832.

It was made with a different Acer model in mind, but it also worked for me.

Some things I‘d like to point out if you are using the tutorial on an Acer Switch 3/SW312-31-P4UV (this isn‘t by any means an educated recommendation! – just what worked for me personally):

  • I couldn‘t access all the settings mentioned in the BIOS setup portion, so I just chose Load setup defaults in the Exit menu and rebooted.

  • They say to erase the disk so your /dev/mmcblk number will match up with theirs in order to avoid confusion. However in my case, it was /dev/mmcblk0p1 instead of /dev/mmcblk1p1 and /dev/mmcblk0 instead of /dev/mmcblk1, so double check which drive is actually needed.

  • The tutorial points out one error that you should ignore. In my case there were two errors that I “successfully ignored“.

  • If you are entering the commands by hand, double and triple check every line before pressing enter. (It‘s umount not unmount.)

  • May all the good Linux karma be with you!

Thank you to everyone who very kindly helped me on my newest quest, you rock :hearts:

4 Likes

Thank you for this great discovery :heavy_heart_exclamation:

I have to wait till my husband stop using this tablet PC (he will be retiring in a few years) but I will certainly try this method when the time is right.
I created a memo in a text format and and copy/paste your posting to safeguard :slight_smile:

1 Like

Is that a secret combo in a bios ? I have a acer bios as well and my bios is locked :sweat_smile:

I do not know about secret... it is what is listed on the Acer website for that make and model...
You ask after I installed the New Zorin OS 16 Lite... so I cannot just pop into my browser history now so... IF you want to know more, you net search it. :stuck_out_tongue:

1 Like

So finally on zorin 16 lite, enjoy the new installation :grin:

...
more or less...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.