Installation error on ROG MAXIMUS 2 790 HERO, BIOS 2102

I have tried to install zorin core 17, but I always get this error:

0.427814] /deu/root: Can't open blockdev
0.4279071 Console: switching to colour frame buffer deuice 240x67
0.430206] UFS: Cannot open root device "" or unknown-block(0,0): error -6
0.430213] Please append a correct "root=" boot optlon: here are the avallable partitions:
0.4302201 List of all bdeu filesystems:
0.4302221 ext3
0.4302251 extt
0.4302251 squashfs
0.4302271 ufat
0.4302301 Kernel panic - not syncing: UFS: Unable to mount root fs on unknown-block(0,0)
0.4302341 CPU: 4 PID: 1 Comm: swapper/0 Not tainted 6.5.0-21-generic #21"22.04.1-Ubuntu
0.4302401 Hardware name: ASUS System Product Name/ROG MAXIMUS 2790 HERO, BIOS 2102 03/15/2024
0.430242] Call Trace:
0.430249] dump_stack_lul+0x48/0x70
0.4302611 dump_stack+0x10/0x20
0.4302641 panic+0x308 0x3a0
0.430269] nount_root_generic+0x1a5/0x340
0.430275] mount_root+6x98/0x100
0.4302781 ? _ pfx_kernel_init-0x10/0x10
0.4302821 prepare_namespace+0x6c/0x2c0
0.4302851 kernel_init_freeable+0x1c1/0x200
0.4302881 kernel_init+0x1b/0x200
0.4302911 ret_fron_ fork:0x44/0x70
0.4302961 ? __pfx_kernel_init+0x10/0x10
0.4302991 ret_from_fork_asn+0x1b/0x30
0.4304071 Kernel Offset: 0x38e00000 from 0xffffffff81000000 (relocation range: Oxffffffff80000000-Oxff

I have searched for solutions on different forums and this one. but still can't find a solution.
Captura desde 2024-03-25 00-54-42

Much of the above output suggests to me a corrupted .iso on the USB stick.

Potential causes are

  • A bad USB stick
  • A corrupted download of Zorin OS
  • A corrupted burn of Zorin OS
  • A bad USB port

The first three can be addressed by redownloading the Zorin OS .iso, checking its SHA, burning it with a reputable .iso burner or Ventoy to the USB Stick (Ventoy is just drag and drop rather than burn) on a different USB Stick.
If available, you could try plugging into a different port.

1 Like

Thanks for your reply.

  • I have used 3 USB sticks and in all I get the same error with Zorin OS, but with distributions like Fedora or Ubuntu they install without any problem.
  • I have downloaded and tested the Zorin OS ISO image.
  • I have used several USB ports on my PC

I have always liked Ventoy because of its ease of use, but I noticed that Ventoy doesn't lift any Linux distribution, it always gives me this error.

So I opted to use Rufus or balenaEtcher, with I am the installation process works fine with Fedora and Ubuntu, but in Zorin OS I get the error.

Maybe the Problem is the Kernel. It could be that the Kernel doesn't support Your Board or other Hardware.

Another Thing: Did you controled the Checksum of the ISO File?


When I assembled my pc, Ventoy worked perfectly with any Linux distribution, so I found it very strange that it stopped working.

The only thing that had changed on my PC was the BIOS, so I decided to downgrade the BIOS version.

With BIOS version 1303, Ventoy started working properly again, and now it recognizes all Linux ISOs and let me install Zorin OS Core 17.1 perfectly.

With this BIOS version it also let me install Zorin OS by burning the ISO on my USB stick.

Solution: Downgrade the BIOS version to 1303

1 Like