Installation issue


I have a TOSHIBA A660 laptop have intel i5 450M and GPU geforce GT 330M, and I attempted to install Zorin OS 17 using a USB flash drive. I tried installing it using the safe mode. However, during the installation, an error kept appearing.

After the installation process was completed, the system was unable to boot and crashed.

I try ubuntu and i face the same issues

Can you get it to boot in live mode? If so, can you please install Synaptic Package Manager from Software (yes you can install apps in live mode, they just don't stick after install!),
then try this:

install the "xserver-xorg-video-intel" if it is unchecked.

Just to add Toshiba's are notorious when it comes to GNU/Linux!

It can't boot after the instalation

But i can boot with my udb drive and use the trying option

I try ubuntu but i face the same error

Which graphics are you using?
You can double check using LiveUSB if needed:

sudo lshw -C video

It seems likely you need to boot from a different kernel.
This can be done by completing the instalaltion and upon reboot, immediately entering the Grub Menu, selecting Advanced Options for Zorin and selecting the (Recovery) kernel.
From there you can enable networking, then back up to the recovery menu and down to Root - Drop to Prompt.
Using that terminal, you can install a working kernel (We need to know your Graphics in order to suggest a kernel.)

I m sure that i have GeForce GT 330M GPU

But i have probleme the option of tring zorin os not working

And he just keep showing that
And when i pres the power button to force my laptop to shuydown it showme this message

Can you test Zorin OS 16?

I believe that the last supported Nvidia driver for 330M has a conflict in the 6.2 kernel.

This may be resolved with the 6.5 kernel or by using the 5.15 kernel. Zorin OS 16 is using 5.15.

You might fare better with ArchLinux
Laptop/Toshiba - ArchWiki

or LinuxMint

You could also see if a 32-bit distro such as Devuan 4, MX-Linux, or Antix.

Thank you i try pop os and it work now

1 Like

I tried as you said, but I faced the same problem. I tried Pop!_OS, and now my PC is working well

Can you check if there's such special settings in BIOS related to graphics?

I have already installed Zorin 17 on too old mac mini, 2010 model, having only 256MB GPU GeForce 320M and indeed it works fine with kernel 6.5 using nvidia legacy PPA

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.