Installation problem with AMD GPU, Wi-Fi Adapter not recognized (Dual Boot Win10 + ZOS 16)

Hi guys,

I decided to dual boot Win10 and Zorin OS 16 Beta because I need Linux for work related troubleshooting. During the installation I had a lot of issues with the GPU driver I guess.

After booting up the USB and choosing the first option "Install Zorin OS", I was getting only blank screen with the default wallpaper and the only thing that I can do was moving the mouse pointer and nothing else. I have dual monitor setup (second monitor is portrait flipped) and after choosing the install option, the setup was giving me "no signal" message on the primary monitor and it was switching the picture on the second monitor, which was really strange.

Then I rebooted and tried the second option "Install Zorin OS (safe graphics)", successfully installed the OS but after the installation and booting up, I got the same problem (blank screen and "no signal" on the primary monitor). During the installation, my Wi-Fi adapter wasn't recognized at all.

I have RX 5500 XT 4GB and the Wi-Fi adapter is Lanberg NC-1200-WI based on Realtek RTL8812BU.

Any suggestions on how to fix these issues will be really appreciated.

These are the complete specs of my PC:

Processor: AMD Ryzen 5 2600
CPU Cooler: NZXT Kraken M22
Motherboard: Gigabyte AB350M-DS3H V2
RAM: 2 x 8GB DDR4 3000Mhz XPG SPECTRIX D41
Storage 1: 120GB Samsung 650 SSD
Storage 2: 500GB Samsung NVMe 970 EVO
Storage 3: 500GB Samsung 860 EVO
Storage 4: 1TB WD Blue 7200pm
PSU: Cooler Master G650M
Case: Xigmatek Venom X Arctic White
Monitor 1: AOC 24G2U 24" 144Hz IPS FHD
Monitor 2: BenQ GW2480 24" 60Hz IPS FHD
Keyboard: eShark Kodachi TKL
Mouse: Glorious Model 0-
Mousepad: Genesis Lighting Boron 700 RGB
Wi-Fi Adapter: Lanberg NC-1200-WI
Controller 1: Xbox One Wireless Controller
Controller 2: Genesis PV58 Wireless
Headphones: Sony WH-CH700N
Microphone: Varr Mini
Speakers: M-Audio BX4

Have you tried this driver for your Wifi Adapter?:

Have you upgraded Mesa?
Can you give the terminal output of

uname -a

You might try:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update

sudo apt install mesa

Now everything is fine. Thank you!

1 Like