Installation problem

I am a new forum member and since I wasn't verified I couldn't finish editing my post which I will do now. So let's get to it...

I created the installation USB drive from the Zorin OS 15.3 iso.

ISO image mode

I pluged the USB in, restarted the PC, pressed F12 while booting to select the USB drive from the boot menu. It starts booting then I get this error message.

What should I do? Thanks!

I would recommend DD mode, actually. I am not sure why Rufus suggests otherwise...

I tried DD mode, I get the same error message as I got with ISO mode.

Ah, I see the error message now. I did not see that screenshot earlier.

Are you plugged into a 3.0 port? Try switching USB ports.
Does that computer have Windows installed? If so, please be sure to Disable Secure boot in the UEFI settings (Computer motherboard at startup) and disable Fast Boot in Window Control Panel > Power settings (Fast boot locks the drive, preventing write access).

Did you check the MD5sum?

You may try a different USB stick. The USB stick you are using may not be getting recognized as removable Media.

@Aravisian MD5?
Did you mean check the SHA256 checksum as published by Zorin?

I saw this error message when USB connection is lost during the installation.

Since I have no information regarding your hardware, it is difficult to say for sure. But in my case, it was a bug in the BIOS of Gigabyte M/B. It loses USB 3 port in the process of booting.

If you have not tried it yet, it is prudent to use USB 2 stick on USB 2 port for Linux installation.

I see you are using old version of rufus, try getting 3.15 and try again. Secondly what type of pc/laptop is it? if it is a old pc/laptop that does not have UEFI then set mode as BIOS Only with MBR otherwise set it as GPT and UEFI. If laptop has got UEFI.

Did I say Jeep instead of HummVee? :smiley:

1 Like

I tried to install it using another USB port and another USB stick.
I get the same error message.

Fast boot was already disabled (to counteract random crashes after a Windows 10 update) when I tried installing Zorin OS previously.

I haven't found secure boot in the UEFI settings. Is there another name for it maybe?

It may come down to the hardware you are using.

I wonder if these are related...

As FrenchPresses suggestion sounds the most like what can cause it, aside from the USB stick itself.

You might try burning to the USB stick with Unetbootin instead of Rufus (Rufus is pretty good) just to see if reformatting the stick and using a different burner makes a difference in how it behaves.
If you have DVD drive and some spare DVD's, that usually did the trick for me on installations- USB installing has always been a bit fickle - no matter which Operating System you are installing.

I checked the SHA256 checksum for the downloaded Zorin OS ISO file with Quickhash (never ever done this before), it's correct.

1 Like

@ZorroOS What machine are you trying to install ZorinOs 15.3 Core on?
Make, Model, Processor, RAM etc

I noticed something strange. There is a storage device power switch in my PC which enables me to turn on/off my SSDs and HDDs.
I only had the power turned on for the SSD with Windows 10 installed and the HDD with my Windows data. The Zorin OS installation thumb drive was not connected.
No storage device was connected and powered on which had Linux installed.
When I powered on the PC and I entered the UEFI boot menu and I still had the option to boot from "ubuntu".
How is this possible?

Using Unetbootin reesulted in the same error message.

The entry for Ubuntu (or linux) boot is stored in the EFI partition, separate from the partition on which the Operating System is installed. I bet if you select to boot from Ubuntu, it would fail.

Are you putting the USB stick into a USB Hub or directly into computer port?

Have you tried using a different USB stick and a Different USB Port?

Try checking ISO if there is an error or not. and try using the latest version rufus.
Try this check:

I plugged the USB stick directly into the USB 2.0 port of the PC.
I tried another USB stick as well. I tried formating the USB installation stick with Etcher, Rufus and Unetbootin. I get the same error messages (unable to enumerate USB device).

Do you have the option to enable IOMMU in the BIOS settings of your motherboard? That may help resolve.

You may also try (tedious) completely wiping and reformatting (blank) the USB stick to FAT16 (If the burner disallows FAT16, go ahead and try as FAT32 anyway after Wiping the USB). Then, plug the USB and burn the Live USB Zorin to it and try booting and installing. Sometimes, faulty data burned into the USB can cause it to malfunction.


Fast Startup is already turned off.

I enabled IOMMU in the UEFI/BIOS settings, installed Zorin OS without a problem. It's working fine.

I can not stress it enough how much I appreciate everyone's contribution and time! Thank you all for your help people.