Installation Woes: Zorin to Windows Transition on Acer Nitro 5

I bought an Acer Nitro 5 laptop with Gutta Linux and decided to replace it with Zorin. The installation was normal and quite easy; however, upon completion, the touchpad and Wi-Fi did not work.

I tried several solutions found on the Zorin and Acer forums, but nothing worked. So, I decided to remove this Linux distribution and install Windows, but that's when the biggest problem started. Now, I can't install any other system. When using a bootable USB drive with Windows, the notebook doesn't recognize it. When trying a USB drive with Zorin itself, the following error message appears: "problem loading x.509 certificate -65."

How can I solve this?

At any point, did you disable Secure Boot in BIOS / EFI Settings?

It sounds like secure boot is your primary issue.

"I'm not sure if I changed anything about this, as I've tried many things in the past few hours and I'm quite new to Linux. But I'll take a look here."

"Secure Boot was enabled. I did some research and learned how to disable it. I tried again, but it still didn't recognize the Windows USB drive."

Some things you might try:

  • Try a different USB stick. The current one may have corruption on it.
  • Try a fresh download of the OS .iso
  • Reset all BIOS settings to default. Once done, go back in and disable Secure Boot.

The errors you display in your O.P. shouldn't create a no-boot issue, so there must be something else going on here.

I managed to solve it. All I needed to do was to create a bootable USB drive in GPT mode, as I was using UEFI.

Thank you!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.