Installation won't work, loops endlessly

Hey everyone,

I've been a windows user my whole life and never used Linux (besides some Ubuntu while college). Since MS keeps making the privacy worse and bad design decisions, I wanted to try out Linux and quickly liked Zorin since it feels very familiar to me which I thought would be a good start. Tried it via USB-Drive, liked it and now bought an 512GB SSD to install it on while keeping Windows as my main for now.

But I got some troubles installing it (while I could install it in a VM without any problems):

At first (since I don't want grub, I'll just use the boot menu) I unplugged all my other drives and kept only my SSD to install Zorin on it but I tried it later with the drives plugged as well. USB-Bootstick with 17.1 loaded, I tested everything out, worked fine. Then, when it came to the installation destination I got the "ubi-partman failed with exit code 10" error.

I looked it up and found an article (How to solve "ubi-partman failed with exit code 10" on ubuntu 18.04) which said I need to create a 200MB partition for it being able to boot, so I did that. Now the error doesn't show up anymore and it went through to picking my region and creating my user account.
I did that but afterwards the installation-wizard-window closed and the cursor kept spinning infinitely while still being able to use the demo. I waited ~30 mins, hoping at some point something would happen, but nope.
On GParted I tried to track if something happens on the partitions and while there had initially been written ~10GB of data on the drive, nothing happened afterwards.

So I'm a bit clueless what to do now. Am I doing something wrong? I've also tried it with an ISO file of 17.0 and 17.1, tried different USB-sticks (since one apparently broke completely in the process - or at least windows can't format/use it anymore). Any clues? Looking forward to any ideas, I really would like to try and test it.
I've heard Linux might be become a struggle for a long time windows user but I wouldn't have thought this would start with the installation already. :wink:

Thanks in advance, have a good day.

Is fast boot and secure boot in BIOS disabled?

2 Likes

In addition to the suggestion above, check whether your drive is set to AHCI or RAID. AHCI is the one you want. It sounds like you are experiencing disk formatting issues - including on the USB stick (I would try to resurrect it by using the LiveUSB or Zorin OS to dd write the entire USB stick and format it to FAT32).

2 Likes

Thank you for your answers!

Fast and secure boot are both turned off.

I've honestly never heard of AHCI/RAID, how do I see what it's set on? And furthermore how do I change it? Does changing that effect my running system?

Windows OS can use AHCI (which is even recommended on most systems) so you have minimal risk. Launch Windows Device Manager after boot and ensure everything is recognized.
I highly recommend making backups of all important files and data.

You can check (It may well already be set to AHCI) in your BIOS Settings, accessible by tapping F2 or F8 or F10 or F12 - depending on the manufacturer - at boot.

1 Like

In the device manager everything is recognised including the drives and the SATA-mode is already AHCI. :confused:

1 Like

Can you please give the Make and Model specs of the computer?

The normal things all check out - so it may be a driver issue on the hardware.

1 Like

Sure:
AMD Ryzen 7 2700X 8x 3.70GHz
Asus ROG Strix X470-F Gaming AMD X470
Asus GeForce RTX 2080 ROG Strix OC 8GB
Corsair Vengeance RGB PRO 32GB DDR4 2666MHz C16
be quiet! Straight Power 11 650W
NZXT Kraken AIO

Using 1x 1TB nvme SSD and 2x 2TB HDD by Western Digital for windows
Trying to install it on a 512 GB Intenso SSD

I'll try it again later with a newly flashed 17.1 stick. I dunno, maybe Etcher got something wrong, I'll try it with a different software.

Didn't work out either... when I pick the EFI-Partition in the installation (like described in the article) it gave me an error it couldn't resize the partition or something. And afterwards it got back to the spinning wheel.

While trying to install it I reformatted the stick to FAT32 and now Windows can work with it again, thank you!

Alright, I got it working.
I'm not sure if it's really the reason why it worked out in the end but I unchecked the two boxes which said to install updates and additional third-party software for printers.
So yeah, I'm actually writing this from Zorin OS.
Thank you for your help nonetheless! :slight_smile:

3 Likes

Doing that simplifies installation and has helped others in the past. You can always choose to install updates and third-party software later post-installation, once you have succeeded to achieve a proven working operating system.

Yeah, that's what I did afterwards.
But how should you know that a built in feature of the installer crashes the installer itself? Wouldn't have guessed that. But it's all good now, I'm happy with Linux so far.

It is not common that it crashes the installer.

1 Like

Yeah, obviously. But I wouldn’t have thought that to be the problem. :smiley:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.