Installed Minecraft from the official .deb file at their website, got an error

So I installed the official .deb file from the minecraft website, the installation worked and the launcher opened. However it was stuck on a blank screen


So I checked the launcher log file, and I found out about this particular part that I believe is the problem:

`[Info: 2022-11-03 14:07:48.587883217: root_window_manager.cpp(57)] Main window has been opened: 0x564a66a118c0

[Info: 2022-11-03 14:07:49.267551300: LauncherAppBrowser.cpp(83)] Will launch a Chromium subprocess with command line string: /proc/self/exe --type=renderer --log-severity=info --user-data-dir=<WORKDIR>/.config/cef_user_data --launcherui --workdir=<APPDIR>

[Info: 2022-11-03 14:07:56.611325252: Xal.lib(0)] XAL: [op 140316044692944] Operation UploadTelemetryEvents is starting

[Info: 2022-11-03 14:07:56.611611360: Xal.lib(0)] XAL: [op 94877543794752] Operation UploadTelemetryEventsWithDelay succeeded.

[Info: 2022-11-03 14:07:56.612375322: NetQueue.cpp(695)] NetQueue: Starting net action` [`vortex.data.microsoft.com`](https://vortex.data.microsoft.com/)

[Info: 2022-11-03 14:07:57.677152886: NetQueue.cpp(484)] NetQueue: Primary ip: 20.42.65.84, Host:` [`vortex.data.microsoft.com`](https://vortex.data.microsoft.com/)

[Info: 2022-11-03 14:07:57.677323222: NetQueue.cpp(573)] NetQueue: Action finished:` [`vortex.data.microsoft.com`](https://vortex.data.microsoft.com/)

[Info: 2022-11-03 14:07:57.677601456: NetQueue.cpp(615)] Action finalized: vortex.data.microsoft.com

[Info: 2022-11-03 14:07:57.727831865: Xal.lib(0)] XAL: [op 140316044692944] UploadTelemetryEvents failed with HTTP status 400

[Warning: 2022-11-03 14:07:57.727924954: Xal.lib(0)] XAL: [op 140316044692944] Operation UploadTelemetryEvents failed with result: 0x80004005 - Generic failure

What should I do to fix this issue?

Personally I couldn't understand the problem but I know that there are many Minecraft versions on Software Center, didn't you tried one there?