Installed pipewire. Uninstalled it. Broke my lovely zorin?

Kindly help. I am getting a black screen and can't get into the os. I ran some commands to get back to pulseaudio since I encountered a problem with pipewire. Had initially installed pipewire to better my sound which is the only problem I have with zorin. But Please somebody help me get my system back running!

Gday @hanitsharma ,
Do you remember the commands you ran to remove pipewire?

Is this dual boot or Clean install ( Zorin only?)

Is this a new/recent Install?
If so & you have you files backed up, a quick solution is a reinstall.

it is dual boot with windows. (i don't know how it makes a difference, if you could elaborate i would be thankful)
i had been running zorin for about a few weeks now. i love the stability of the system and just the overall experience is far better than windows. i don't have the files backed up.
i ran the following commands to disable pipewire:

systemctl --user unmask pulseaudio
systemctl --user --now disable pipewire-media-session.service
systemctl --user --now disable pipewire pipewire-pulse
systemctl --user --now enable pulseaudio.service pulseaudio.socket
sudo apt remove pipewire-audio-client-libraries pipewire

I ask because i now know what to ask,
Do you get the GRUB appearing & this happens after selecting Zorin?
Or do you not see the GRUB at all?

i have selected the zorin grub as default. so zorin is on the top of my list. i see the grub. press enter. and then the screens pop which i have uploaded.

Sorry i have to go offline,

Please look threw this link, is has several fixes that may help, until someone some help further.

Keep us informed.

Also i don't think removing pipewire is the reason behind this error.

Note: Zorin is based on Ubuntu 20.04.


sudo apt install -y zorin-os-desktop

To install the DE (Desktop Environment) and get back into the graphical interface.

i was able to get back the gui by running the following commands.

sed -n '/^Remove/ s/([^ ]*//g;s/Remove: //p' < /var/log/apt/history.log | tee uninstalled
sudo apt update
sudo apt install $(cat uninstalled)

on running pactl info , i see that i am running PulseAudio (on PipeWire 0.3.68)

source: Stuck at login screen tty1 (Ubuntu 20.04.2) - Ask Ubuntu
For any such future occurence, would it better to have a timeshift snapshot? and/or is there a way to backup the whole system (or atleast the files)?

is it safe to run pipewire since it is not as yet officially supported by zorin? i believe the next major zorin update to zorin 17 should be based upon ubuntu 22 which will include pipewire as default.

also, i am new to the forum and to linux. i had earlier experimented with manjaro but given up on it after breaking the system and not being able to retain it. it takes a lot of effort to set up the machine as you want it. but i returned to linux (to zorin this time) since it gives me immense satisfaction to run open source software and the utter ease with which the system runs when its running properly. currently i am experiencing great benefits with my laptop's speed and battery life. its just a honour and a pleasure to run linux no matter how salty at times it can be.

i would like to continue to carry the discussion forward regarding the tinny laptop sound signature as compared to the same hardware running on windows. the lack of tuning seems to be the major issue here. is there absolutely no way to get around this issue except to use pulseeffects or easy-effects to tune it oneself?
should i post separately to carry forward this discussion? forgive me, but i do not know exactly how the forum works and just want to know the etiquette to navigate my way around the forum as a newbie. THANKS!

Look into:

There are some backup options in the packages they build and maintain that you might find useful.

You should start a new post on the forum for a different issue. e.g. poor sound. :+1:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.