Installed Zorin and all I have is a Grub prompt!

I installed Zorin on my MS Surface 3. I selected the option to have it installed side-by-side with Windows 10.

When I restarted my PC all I get is a Grub prompt. If I type “exit” I can get back into Windows 10 but I can’t see how to get to Zorin.

Any ideas?

Thanks
Andrew

2 Likes

Had the same issue on two desktop machines.

Try installing with and without “Downloading Updates during installation”.

After repeating the installation it worked. Not a good first impression.

I have installed probably 30 different distros in the last couple of months to find the right flavor for me and never had this issue with KDE Neon, Kubuntu, Ubuntu, Xubuntu, Pop OS!, Mint.

Still, I’ll be using Zorin as my daily driver for the foreseeable future. Just bought the Ultimate edition to support the team.

2 Likes

Hi, Are you saying reinstall twice, once with and one without?

Thanks

1 Like

Pretty much. I was watching the installer and something like “updating grub” flashed past my retinas. So I tried different options.

Full disclosure: I am a Linux novice, so this may work or not.

1 Like

When I walked away from Windows- I really walked away from Windows. I do not even use WINE.
I have noticed that installing alongside Windows is trickier now than it used to be. With needing to disable Fast Boot and Secure Boot and jump through Windows hoops first… I have been content to let Swarfendor field such questions.
But feedback likes yours helps Zorin Team to examine problems and user experiences.

Having to install with or without… It is interesting: I had noted previously that Installing with “Install 3rd party” unchecked is often better. Yet, in a few cases, it can mess things up with the Ubiquity installer too (Ubiquity is the Ubuntu Installer that installs the OS from iso to machine).
It’s a good starting point for looking into why some are having the experience you both describe.
I always go with Unchecked, then update and upgrade after. But for those that use Nvidia graphics, they need to do it the other way around. It’s a tough call.

Hopefully someone will chime in with something more knowledgeable than my useless post here. But I will continue to dig deeper into this issue and see if the common connection can be found.
'Cuz I wanna know.

You and me both. I hereby promote you to “Novice Adept.”

2 Likes

andrewjmdata, please try the Boot Repair procedure here:

https://help.ubuntu.com/community/Boot-Repair

1 Like

There is a “repair grub” utility on your Zorin live installation medium you can use.
You probably set something wrong for the boot loader installation (path?).

It’s really easy to understand and only took me like 2 minutes.

2 Likes

Will give it a go. Thanks

1 Like

Depending on whether the Windows 10 is installed to GPT instead of mbr I would always recommend the Matthew Moore’s nonconventional method of dual booting with Windows:

2 Likes

Tried the double install but, sadly, no joy. Tx anyway.

1 Like

Noticed url error for YouTube link now corrected.

1 Like

This is getting a bit crazy!

I did the grub fix thing and it had said all was repaired.

Then rebooted and it just took me straight into windows.

Found a post that said issue a DOS command "
bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi"

Rebooted and no difference, straight back to windows.

Seems my laptop doesn’t have a way to let the user decide which OS to choose. Is that what grub is supposed to do? If so, why doesn’t it show on screen before anything starts to load?

Thanks for all the help and suggestions so far.

Andrew

1 Like

Could you please check that your mbr, bios etc are all in agreement as to whether to boot UEFI, Legacy or otherwise?

For example, if BIOS is set to Legacy but mbr is set to UEFI, then it will prefer UEFI, resulting in the legacy mode boot option never appearing at all.

Can you check through each bit of this tutorial and see if anything looks like it may have been missied or could help:
https://linuxhint.com/ubuntu_boot_repair_tutorial/

1 Like

This is why the Matthew Moore method … just works!
You also need to make sure you have turned off the Advanced Power setting that are hidden under ‘Power Schemes’ in Control Panel - Windows 10 never shuts the hard drive down but puts it to sleep.

1 Like