Installer Stuck on Updates and other software

So my Windows 11 crashed and I didn't had any other bootable pendrive except for the zorin core one. Now that I tried to install zorin, it got stuck on the Updates and other software tab. My cursor is just rolling and nothing is happening. My pc is sitting in this position since last night. I had saw couple of other answers but didn't helped me. I have secure and fast boot disabled. I do still have old windows file BUT i do have 2 more different SSDs and one of them is empty. IDK what could be the problem? It use to me really smooth. And yeah I have used this same pendrive before also in the same pc as I'm now and it had worked flawlessly..... I don't have any backup pc so I can't do heavy task. Altho I managed to make a windows 11 bootable pendrive in Live Mode but it is also not working (unetbootin sucks). Live is really slow so i need to install it on my ssd.....
Thanks in advance

Try booting the LiveUSB and then enter "Try Zorin"
From there, double click the installer to run it.
Do not connect to the internet. Proceed to install and uncheck the box for installing updates as you install
Proceed toinstall using either the Wipe and install, install alongside or "something else" options that you prefer and see if it gets stuck.

If it get stuck again, I highly recommend downloading a fresh .iso of Zorin OS and reburning it. It is likely that something was lost due to packet drop during download if the issue persists.

1 Like

I tried installing without internet but it didn't worked. Ig I'm gonna wait for zorin 17 as it's gonna launch today anyway....

1 Like

In this case, I'm glad that your Windows 11 crashed, and now you want to use Zorin OS 17; that's a very good decision. :nerd_face:

Do you have the Windows installer .ISO file? If so, you can extract that to the root of a USB stick (NTFS formatted) and then you should be able to boot from it. If it's a generic Windows .ISO image, it most likely won't have SSD / NVMe drivers though - but, can be added if needed.

You can do the same with Linux installer .ISO's as well; format the USB in NTFS, then extract the .ISO to the root of the USB.

**Note - this only works with UEFI enabled systems. Legacy boot systems won't work this way.

A few things to consider:

  1. Did you reboot or shutdown before booting the Zorin installer? Newer Windows versions (10 / 11) keep some busses active through a reboot. My dual-boot Win11 / Zorin setup - if I don't shutdown Win11 before booting Zorin, then I don't have sound and some other things. That's one possibility. You can break the bus loop by pulling the battery or puling the RAM (with power off of course), then push the power button a few times, or hold it down for a few seconds - or - boot to a Win installer, then do a shutdown - either should break the bus loop.

  2. Do you have any AHCI / RAID settings for your storage options in BIOS? If so, or if you have any options for AHCI - enable AHCI and try to boot / install again.

  3. Is your machine a Legacy boot type device? I.e., no Secure Boot / TPM, and usually computers that had older version of Windows. If so, you could use Rufus and select the MBR writing method, or use Unetbootin - that still uses the older MBR writing method; as well as UEFI.

Just some possibilities! :grin:

1 Like

Thanks for the suggestion, I would definitely try that. I didn't knew that we could just extract any .iso file and boot into it in UEFI.
I always shut down my pc since I don't use sleep or suspend. Ig i have AHCI enabled, but i would surely confirm that. I'm using UEFI plus I also have disabled Secure Boot/Fast Boot.

1 Like

Yeah i had been waiting for Zorin 17. Coincidently the recent events were on perfect timing.....

The same thing happened to me few days ago which we have discussed here: /dev/sda: Input/Output error & the zorin installer very slow

Boot into Live environment and check if any of your disks have any bad sectors or not. The reason behind the installer being so slow is Bad sectors in disk.

After a long fight, I managed to install Zorin 16.1 and then upgrade to 16.3 (there is still no option to upgrade to 17 core yet)
What I did was :-

  1. Select Try Zorin
  2. Then Disconnect the internet
  3. Mounted some of drives (I had mounted the one in which I had to install Zorin)
  4. Then idk if its necessary but I had changed my theme to Adwaita (I had done all these process without this one and it hadn't worked. So you can give it a try)
  5. Then I started then the Install Zorin which is on Desktop.

After selecting my keyboard layout, zorin asked me to dis-mount my all mounted drives. I allowed it and bang, the process was once more smooth as butter. Zorin got installed in just few minutes.

Thanks for the suggestion. Fortunately my problem is solved but thanks for trying to help me :smiley:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.