Installing anbox/genymotion or other android software


Any help is apprecaited as I was wondering how to properly install Anbox/ virutally run Bliss OS/Remix Os as I have been trying for a few weeks now.


1 Like

Reading the github for anbox, It is no longer maintained and the maintainer suggests waydroid as an alternative.If you don't mind using an alternative I suggest giving it a try

It also has instructions for ZorinOS
You can try posting the errors you face, and we can troubleshoot them.
We can try Bliss OS after waydroid :wink:

1 Like

Hi, I myself need to do something like this.

When I first tried back in December 2022, I started following the procedures on the Anbox wiki but got stuck on the issue of kernel modules (Anbox needs certain kernel modules and I couldn't work out if I had them or not, if they were being loaded or not etc).

Personal life events came up that meant I didn't get round to finishing the process. I note that since then the Anbox site has changed, they got rid of the instructions I was trying to follow and now offer a simple Snap package. And they say kernel modules shouldn't be an issue.

But as @Kayjzjzk said, Anbox is now deprecated in favour of Waydroid. But if you're on Zorin Lite (like I am), then you have the X11 graphical server, not Wayland, so Waydroid is no good for Lite. (Unless you go through various steps that allow using a Wayland app on X11 which seem very complex to me.)

To know whether your OS is using X11 or Wayland, you can type the following in a terminal:

I've been getting by using the Windows version of WeChat in Wine but it's problematic so I still want to try something that can run Android software. I just haven't tried again yet, because I was trying to sort out multiple issues with 3 different laptops and an iPad all at the same time and it was doing my head in. :stuck_out_tongue_winking_eye:

I did a little reading on Bliss OS, and on Gnome Boxes (which might be the simplest way to get a virtual machine up and running. Simplest but least configurable.) If the Anbox Snap doesn't work, and Waydroid is not an option, a VM with Bliss might be the last resort.

I had a quick go at following the new Anbox installation instructions, because WeChat in Wine was being a complete pain this morning.

But I fell at the first hurdle again, the required kernel modules. (This is in Zorin Lite 16.3, results may vary in other versions of Zorin.)

The terminal command

sudo modprobe ashmem_linux

gives no feedback whatsoever.

The command

ls -1 /dev/{ashmem,binder}


ls: cannot access '/dev/binder': No such file or directory /dev/ashmem

And the command

rep binder /proc/filesystems || echo "binderfs support is missing"


nodev binder

And in case anyone's wondering, secure boot is off.

sudo mokutil --sb-state


EFI variables are not supported on this system

But I'll try the Snap anyway, just in case.

snap install --devmode --edge anbox

downloads the snap but then gives:

error: cannot perform the following tasks:
- Run install hook of "anbox" snap if present (run hook "install": 
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
The CPU of your computer (AMD A4-3305M APU with Radeon(tm) HD Graphics) does not support all
features Anbox requires.
It is missing support for the following features: SSE 4.1, SSE 4.2, SSSE 3
You can for example find more information about SSE

So even if I could get the kernel modules present and working, the hardware on this machine doesn't have what Anbox needs. Oh well.

Perusing this may be worthwhile:

It seems a lot of users run into this issue.

1 Like

Thanks! Will try tomorrow.

Actually (now that I've got wifi working on the new laptop!) I want to focus on the kernel module issue, as that will affect all the machines I have installed/will install Zorin on.

The Anbox installation instructions:

  • say that Ubuntu has the modules since 18.04
  • do not say what to do if the modules are not present/loaded

On the new machine too,

ls -1 /dev/{ashmem,binder}


ls: cannot access '/dev/binder': No such file or directory

Trying to install Anbox modules from here:

After installing dkms and linux-headers-generic, it fails at this step:

sudo cp anbox.conf /etc/modules-load.d/

It says:
cp: cannot stat 'anbox.conf': No such file or directory

It also talks about an install script to automate these steps but I don't see it or know how to use it :sweat_smile:

Oh wait, does it want me install the Anbox kernel modules after installing Anbox? I thought the kernel modules were a prerequisite for Anbox.

I'll come at this again tomorrow.

TLDR: Even though Zorin (Lite 16.3) says it doesn't have one of the necessary kernel modules, Anbox works! Whatspp and F-Droid work! But WeChat (and maybe other apps) doesn't work out of the box on x86 CPUs. Workaround (libhoudini? libndk?) might be possible.

Well it seems that even though I can't for the life of me get Zorin to stop saying it can't find /dev/binder, Anbox still works!

I installed Anbox

snap install --devmode --edge anbox

Then I installed android-tools adb

apt install android-tools adb

This will allow you to install .apk files (the installer files for Android apps), but only after you allow Anbox to install from unknown sources. To do that, in the Zorin Menu, run "Anbox Application Manager", let it load, click on the "Settings" icon, scroll down to "Security" and then allow "Unknown Sources".

Then download the apk and in the download folder, right-click on empty space and select "Open Terminal Here", and then:

adb install APPNAME.apk

I successfully did that for WhatsApp (go to official site, download "Package installer") and F-Droid.

Once I'd done that, Whatsapp and F-Droid are there on the homescreen, successfully installed and working! (So far... I still need to test all Whatsapp features like voice calls etc. F-Droid successfully installed a game, Lexica, and it plays fine.)

Anbox Application Manager on Zorin Lite 16.3

Whatsapp in Anbox on Zorin Lite 16.3. Note the video call and audio call icons at top right, which the "Whatsapp for Linux" versions never give you. Yay!

WeChat, on the other hand, is another story. :melting_face: It seems it uses "native libraries", built specifically for the CPU architecture in phones, Arm; not for PC chips, x86_64. So trying to install the standard Android apk on a PC, even in Anbox, fails. (Both the Chinese weixin apk from the official site and the English WeChat apk from APKpure.)

adb: failed to install wechat.apk: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]

There are a few ideas out there on the web (in English; more in Chinese but my Chinese isn't good enough) about how to deal with this, but most of what I've seen so far is beyond my skill level or will require more research (e.g. libhoudini or libndk Arm-Intel translation layers).

I did try one thing I found, but it didn't work, and in fact makes Anbox crash every time I start it. Undoing returns Anbox to working as normal.

What didn't work for me

That was the last thing on this Github page.
sudo snap set anbox software-rendering.enable=true
sudo snap restart anbox.container-manager
After I realized this didn't work and made Anbox crash, I changed "true" to "false", restarted Anbox and it went back to OK (but still can't install WeChat).
sudo snap set anbox software-rendering.enable=false

This native libraries / architecture issue makes me wonder if WeChat for Android would even work, out of the box, inside a virtual machine with BlissOS. (My last resort and/or next step. That or Windows in a VM. Another possibility I just saw: WeChat UWP.)

Anyways, Anbox works on Zorin. Whether the Android app you need works on x86 CPU is another matter.

Using the instructions linked below, I was able to install a script that sets up in Anbox the following:

  • Google Play Store
  • libhoudini, which allows you to run Arm-only Android apps (like WeChat) on x86 PCs.

After that, I was able to install and run "Arm-only" WeChat. Able to send and receive text messages etc. Unfortunately it crashes every time I try to make a voice call. (And not being able to make WeChat voice calls is a deal breaker for me. I'll keep Anbox for WhatsApp and maybe a few other things, and investigate other options for WeChat.)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.