Installing dkms in new Zorin Lite - It keeps requests CDrom media?

Any ideas why its requesting the cdrom media, can this be avoided?

Installing WiFi driver on an old PC with a new Zorin 16.2 Lite installation.
The command
apt install dkms
Does all of the usual apt stuff except when it comes to confirm with
Do you want to continue [Y/n] Y
It requests
Media change: please insert the disk labeled
'Zorin-OS 16.2 Lie 64bit'
in the drive /cdrom and press [enter]

Z16 was installed using USB.

Is it connected to the internet through a means other than Wifi?

It will ask to use the CD ROM (Which is just your USB Installation media for Zorin OS, so you can insert the USB stick and use it) if there is no internet connection.

Tried the installation USB, no go, it wants nothing but /cdrom. I might try this as a work around:
rename /cdrom
recreate /cdrom as a symbolic link to the mounted USB installation media
rerun dkms installation
followed putting everything back the way it was.

Connected to the internet - yes. I thought it would grab everything from the internet and not require the installation media as well. It may want to work with the original installation media because dkms looks like low level stuff that's messing with the kernel.

Its a PC using powerline LAN adapters. I want free it up from cables & those adapters.

Yes, if you are connected to the internet, the CD:ROM is not needed.

No, you do not need to rename anything. You can enable the CD:ROM as an installation source in Software & Updates > Other tab. It is the first entry. Tick the box to enable. You should always disable once finished with your installation. That being said, I will repeat now that you do not need to do this if there is an active internet connection.
The dkms package is most certainly available on the server.

I am not sure why this is giving you such an Odd Output. It is currently after 3am my time here, - So I will continue looking into this after getting some rest. But I needed to address the above issues, immediately.

The symbolic link method worked.
Once that was done installing the wifi drivers was straight forward. The whole installation was only three commands. I'll do something in Tutorials and Guides for this one cause its a bit cryptic for the casual user.

1 Like

I look forward to reading this...

Since it was a new install I reinstalled Z-lite and everything went well. No request for /cdrom, all very normal.

I fully agree. Something clearly went wrong - and without knowing what went so wrong that installing normally led to it asking for the Media instead of using APT, you may have run into further problems later on even if able to workaround this hurdle temporarily.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.