Installing on 14th Gen Intel CPUs

I have been trying to install Zorin OS 17 Core but keep running into a "Out of Memory. Press any key to continue..." error. My hardware is as follows:

Mobo: Asus ROG Strix Z790-I (BIOS 1801)
CPU: Intel i-5 14600K

I checked the USB drive and the .iso file and they both passed integrity checks.

My suspicion is that the CPU is the issue. After a few minutes the kernel panics and a few lines are displayed (screenshot attached). I noticed in the 3rd line that the CPU field is a "0". I'm a Linux newb so I don't know what it's supposed to be but I would think it should show the type of CPU. Also, I noticed that Ubuntu version is 22.04.1. I read somewhere that the 14th Gen chips are supported starting with 22.04.3.

Does this sound right? Should I swap out my CPU for a 13600K (or 13600KF)? It's still within the return period at Microcenter so not a big deal to do it.

Or, is there something else entirely going on?

Thanks in advance!

Thank you so much for the quick response!

I checked out everything you noted and all was right/correct. I then tried swapping out the CPU with 12th gen one that I had lying around. It still didn’t work. Ultimately, it turned out to be the BIOS on the motherboard. I had updated it to accommodate the new processor. When I reverted it back to the version prior to Asus adding support for the 14th generation processors, it worked!

As you pointed out, I will need to wait for a kernel update before I can update the BIOS and use a 14th gen processor.

Thanks again!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.