Installing on NVME SSD & RST/AHCI problem

Hi everyone!
I’m running Windows 11 on my main nvme m2 ssd (sabrent). Just bought a second nvme m2 ssd (crucial) and i tried to install Zorin OS on this one. The idea was to avoid installing windows and linux on the same drive and keep the two OS separate.
After launching the installer (via bootable usb drive) i received the “turn off RTS” message and i wasn’t able to continue the installation.
I read online that to disable RTS and to activate AHCI i have two options:

  • edit the registry and all the stuff, like showed in the ubuntu guide
  • boot windows in safe mode, enable AHCI in the bios, reboot, disable safe boot and it’s done (this seems the simplest and less dangerous way)

Which is the correct one? Because everyone online seems to suggest the second option and it makes sense to me. But seems too easy (lol)

Thank you so much!

1 Like

Could you explain more detail for second way? Especially to enable AHCI in BIOS, reboot, and disable boot? My pleasure if you add some screenshot.

I love the easiest way :star_struck:

You should boot into the bios and enable AHCI, disable secure boot and fast boot. In windows, disable fast boot and hibernation.

That should square you away. Do realize, by installing on a seperate drive, you will have two boot loaders, in separate devices, so you will have to choose the boot device in order to switch OSs.

If i enable AHCI right away, then windows will not boot. It’s written in the official ubuntu guide about this topic.
Of course there’s a method to boot windows again, but it’s a little bit tricky

The saves way is to remove the windows nvme and install zorin on the second one. So your sure nothing gets messed on the windows nvme drive. I did this and it works fine, all i have to do is press f12 and select from which device i want to boot.

I used windows 11 and i have turned off secure boot and and the tpm settings and for some reason it is still booting just fine.