Installing on old ASUS x61s with radeon gpu chip

Never used linux before, so please be gentle!
I’m trying to install & run zorin on an old (dinosaur) Asus x61s laptop. After many days trying different distros, I eventually found a reference on the ubuntu forum to disable the “New interface card” setting. That finally allowed me to install zorin onto a clean drive. However after the install booting up I got a black display with just a mouse cursor (it moves but doesn’t do anything useful). Putting “nomodeset quiet splash” into the grub allows me to boot successfully, but only with 1024x574 resolution. The laptop has an ATI Radeon HD 4570 chip which should give 1920x1080 resolution. Any suggestions as to where I can go from here, other than making “nomodeset quiet splash” permanent, which is what I’ve currently done. I tried updating drivers in terminal, but it said no new drivers were available. I downloaded a linux driver for the gpu from the amd website, but it’s a *.run file. Despite a lot of looking online I can’t find any instructions for installing it. Guides & forums all say it’ll appear in the “additional drivers” tab (it doesn’t) or it’s “beyond the scope of the guide”. Useful … not.

@Qwerby, Welcome to the Forum.
I just did a web search for “linux .run file” and this came up:

Don’t know if that may help you, but Z15 is based on Ubuntu 18.04, so that article should be applicable.

I also found this:

Maybe you have also found these during your own web searches, sorry if that is the case.
Let us know how you get on.

1 Like

In addition to what Zaba wrote, you should be able to execute .run files by right clicking -> Properties -> Permissions -> check box that you allow it to run as executable. Then when you open it it will run as executable.
Or through terminal: sudo chmod +x ./<file name..run>
Then ./<filename.run>

Thanks all!
Carmar’s solution was the same as zabadabadoo’s link, so tried that. It worked … up to a point. The preliminary process all went fine, but then when it tried to install I got the error:

“AMD Catalyst™ Proprietary driver installer/packager
error: Detected X server version ‘xserver _64a’ is not supported. Support versions are X.org 6.9 or later, up to xserver 1.10 (default:v2:x86_64:lib:xserver _64a:none:5.4.0-52-generic:)
Installation will not proceed.”

I’ve copied that by hand from one computer to another, so I may have mistyped one or two characters.

One step forward, one back …

PS: the error means zilch to me. :frowning:

The driver package covers both 32 & 64 bit installs. The Radeon HD 4570 chip also comes as mobility & standard, but both have the same linux driver package. All the linux dl’s have the same filename.

But … from what I’ve read this chip should be natively supported in linux anyway, yet the os is not picking it up. Besides, the chip has to be linux friendly since the manufacturer provides a linux driver install package (wishful thinking?). It’s always possible the GPU chip is flakey. Over the past year the laptop became so slow as to be unusable. I installed a new hdd (for the linux install), gave it a good clean & dust inside, checked the ram (all fine), heck, all the windoze diags I could run said there was nothing wrong.

PPS: The driver was dated 2013, but then the gpu chip dates back to 2006.

Do the suggestions in this post help? Unable to install Zorin onto my Desktop PC

I started at the top & worked down … then it got beyond my level, so I went to the end where I found the note :
“When using ‘nomodeset’, the resolution cannot be changed. And without nomodeset, you cannot boot.”
That’s pretty much what I have :grimacing:

Following a link in that forum it appears there is a fatal conflict between the more recent versions of ubuntu (and presumably zorin) and some hardware including you guessed it, the gpu chip I have.

The suggested fix (for ubuntu) was:
“1. Create an 18.04 Ubuntu live usb stick
2. Once it is installed the way you want it to be, install Ukuu (kernel manager/installer) and upgrade to the latest kernel available.
3. When its done, upgrade your distro as you usually do, in my case with a sudo do-release-upgrade”

Another poster said:
“You can install a kernel using Synaptic, dpkg, as .deb file… you do not need to use the Ukuu GUI method.”

OK. Steps 1 & 3 are obvious, but I’m at a loss for step 2 (or the alternative). Plus, I’d need to guess what older version of zorin is compatible with the GPU (the OP in the thread gave up, so no help there) and the v18.04 hint was for a cpu that would not work with v19 ubuntu.

So … in summary … the current versions of many (at least all the ones I tried and probably all based on ubuntu) linux distro’s have a bug that means they will not work with my GPU unless I put nomodeset into the grub and that means I am stuck with 1024rez … unless I can find an older version that does work, somehow update the kernel and then update zorin. Does zorin allow you to update even from an old version via terminal or like some distros do you need to install again from a usb? The later would, methinks, wipe out any help from the fix suggested above??? It’s looking like the answer to my original question is it can’t be done because of a bug. I’m happy to be shown wrong!
I should add this is an obsolete laptop which I plan to replace and until then I’m using it to play with linux … if I’m happy, I’ll install it on the new beast when I get it.

To be specific, I meant the terminal steps in the exact post I linked to - post #35. There were three steps in it:

  1. xrandr --newmode “1920x1080” 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
  2. xrandr -q
  3. xrandr --addmode 1920x1080

I did not link to the top of the thread because I did not think it was relevant to your problem. But I may not be fully understanding your situation.

Sorry … I edited that out of my previous reply.
I tried those and got exactly the same error messages as the OP in that thread. I then continued down with the steps to diagnose & deal with that issue and eventually found the note that the inability to change from 1024 res was due to having nomodeset in the grub (and doing what it is apparently supposed to). And nonodeset is needed since fresh installs of current versions of linux do not work with the gpu in question. So it appears to be a catch 22 situation - the fix to allow me to boot at all means I can only use the 1024 res. There was a possible solution suggested, but the OP gave up so no idea if it’d work.

The first part of the thread you referred me to described my original problem, which I was able to “resolve” (from browsing forums) by adding nomodeset to the grub, as the OP in that thread was told to do at the top. That allowed an install & boot.

From the Zorin help page:
“If you have a modern AMD Radeon graphics card (from 2013 or newer), Zorin OS already comes pre-loaded with the official open source AMDGPU and Radeon drivers. No additional setup is needed.”

I read that as meaning pre-2013 gpus will not work. :frowning:

Ah. Thanks. Sorry, I’m slow. I get the picture now but hopefully someone else can help. Unfortunately I’m out of ideas and I couldn’t find anything last night besides the same driver you already found on the AMD site.

Looks like the laptop is a brick then, short of finding an old version of zorin that might work with the GPU … but that’d be blindly guessing. The OP in the thread you referenced gave up at this point and he’d been using linux on other machines for years, so not a novice. Oh well, it’s been an interesting experience. Thanks for the help.

For posterity sake I’m posting the final verdict in case anyone else comes looking with the same problem.

I eventually found that despite a driver package supposedly dated 2013, the most recent version of linux that actually supports the ATI Radeon HD 4570 GPU dates back to 2009 and even then people were starting to have trouble. I found numerous forum posts from 2009-2013 all reporting total failure in installing different distros with that GPU. The amazing part of this is that they were still selling brand new laptops with this GPU in 2009!

So it’ll run in 1024 mode and that’s it. Not terribly useful these days. Oh, I did notice one apparently contradictory thing … when the os asks for the user password before loading the gui, it’s in 1920 resolution, even with nomodeset, but as soon as the gui loads, it switches to 1024 res. Close, so close … but not close enough. :frowning:

1 Like

Probably some thing you thought of already but is there a way you could contact AMD for their opinion on this error? Just to close the loop on that as well?

People tried that back in 2013 on other distro forums. They were told the gpu was obsolete and support was no longer provided. I daresay that answer would be even more true now.

Thanks for confirming. Yeah, I agree.

Oh well … such is life. It cost me a weekend of time and $60 for a new HDD. The later I can write off on my tax return. :slight_smile:

As icing on the cake, attempts to upgrade from win7 to win10 have failed because of a driver issue … and the only driver that wasn’t a bog standard win7 driver was, you guessed it, the Radeon HD 4570. The driver & GPU from computer hell!

Buried on the Radeon website is the note the 4000 series does not support win10. Nor linux for that matter.