Installing on Toshiba Satellite P840

After trashing the Acer Aspire E5, I got this used Toshiba Satellite P840, and I want to make it useable with Zorin OS (Windows 8.1 comes with 23 toshiba apps). I have tried installing w/ secure boot, w/ out secure boot w/ a blank HDD w/ nvidia graphics and w/ reset uefi settings, but everytime I reboot, I just get a black screen and nothing ever happens.

From the Grub Menu, have you tried using Safe Graphics option?

1 Like

No, I will try
After install, if I verbose boot, I can see it is getting stuck on "Loading Initial ramdisk"

ALSO NOTE: I have the Nvidia graphics

1 Like

I found this but I don't understand it, could anyone help me?

Thank you so much! That helped a lot.

Sorry, I was away during the previous posts... but it looks like you have made progress.
Once you have Zorin OS installed, please be sure to use either Software & Updates > Additional Drivers tab to scan for and install needed drivers or

sudo ubuntu-drivers install

This way you can ensure that the Nvidia card works properly post install.

1 Like

It said dpkg had a problem when doing that, so I rebooted and I get the same black screen error now.

When you see the Grub Menu, select Advanced Options for Zorin instead of booting normally. If you do not see the Grub menu, try tapping esc or tab repeatedly when you see the motherboard splash screen.
Enter the Recovery Menu and first go to enable networking.
Once enabled, back up to the recovery menu, then arrow key down to drop to Prompt.
Hit enter...
Then run

sudo nano /etc/default/grub

Arrow key down to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the nomdeset parameter so it looks exactly like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
Tap ctrl+x to exit, then the y key to say yes to save, then the enter key to save the configuration.
In the terminal prompt, run

sudo update-grub

In order to ensure the changes take effect.
Once done, back to the menu and proceed to boot normally and test... IF that gets you past the black screen, we can try seeing what is going on with your drivers.
Please note your Nvidia Graphcis card model in the thread.

1 Like

I am still unable to get past loading initial ramdisk, I have tried reinstall and still nothing past that. Is there any way to get past it? I can remove the hard drive from the laptop and put it in an enclosure to access it from my desktop PC (running zorin os 16) if I need to modify files.

What the link you posted is suggesting to do:
CLI method:

sudo nano /etc/default/intel-microcode

Arrow key down to the bottom of the file and add a line, then paste this into it:

tap ctrl+x to exit, then the y key to say yes to save, then the enter key.
The terminal will revert to normal.
Run update-initramfs -u to configure that change you just made.

If that doesn't work, we can try a different method.

1 Like

I don't have any form of access to CLI or GUI on that install, as I can't boot from this enclosure, is there another method that requires something else, like modifying files


You're a mind-reader.:wink:

That was the other thing I was going to try.

In order to access the Terminal:

That should enable you to edit the appropriate file.

1 Like

I can't access recovery, i get black screen

I wonder if you need to repair Grub, then. Have you tried grub repair?

1 Like

Try pressing

Ctrl+ Alt+ F1 (through to F6)

to get to console login. Then follow the advice in this askubuntu thread:

1 Like

Grub appears and works, but it gets stuck on black screen when I click Zorin, I will try boot repair though

Have you clicked Advanced Options for Zorin, then Recovery?

1 Like

No, I just ran boot-repair and it doesn't work so far, I will check recovery. I have turned off the "Fast boot" feature as it says it only allows Windows to boot.

YES! It booted successfully into recovery mode!!! What do I do now?