Installing OpenCL/cuda for AMD GPU's

I wish to run Folding at home on Zorin. I need openCL to do that. How do I install it. I've tried a few things but none work.

What have you tried so far - and what specifically happened as a result?

ubuntu drivers refuse to install, the usualy mix of year to two year old receipes that worked when they were postedh but do not now. This is what I hoped to find different in zorin but it's the same old linux, go find an ubuntu based guide and hope it works.

Ubunter-drivers... Are you using Nvidia card?

No AMD, I have just tried your suggested guid and after changing the install script where it said ubuntu to zorin it seems to have run. A tip I picked up from YAG where they expected a more explicit syntax that checks for ubuntu, I just guessed and replaced the one mention of ubuntu with zorin. Lets restart and see.

1 Like

Oh well, worth a punt. System starts to boot but block screen I guess when it loads graphics. So that is Zorin knackered already.

In Recovery Mode, you can drop to prompt and undo your recent changes.
And what you just did should have worked - that is actually how I do it... Replace "Ubuntu" with "Zorin"

Well i now have a non functioning system, no idea how to get into recovery mode and uninstall. Already sounds like too much hassle :slight_smile: Luckily this is a test setup made of components I have discarded over time so I can break it and reinstall it but it's all time consuming and a side project at the moment.

1 Like

This is true.:wink:

To get to the Recovery Menu, though (You will want to know at some point), tap the esc or tab or maybe the left shift key beginning when you see your motherboard splash screen.
Tap it like you'll die if too slow.
The reason for the difference, esc or left shift is that MBR would be Left Shift and EFI would be esc or tab ... more or less...

edit:
Crosslink