Installing Steam on Zorin OS 16

If you move to install Steam on Zorin OS 16, you may find yourself falling into a dependency nightmare. You may see "Dependency problems. Steam requires.... But it is not going to be installed."
This is caused by the Focal Fossa Repos containing (an ever so slightly) higher version of some dependencies than the i386 counterparts required by Steam.
This necessitates downgrading the packages (by about .1 version...) in order to install Steam.
The easiest way I have found to resolve this is to use Aptitude.

sudo apt install aptitude

Then use Aptitude to install steam:

sudo aptitude install steam

Aptitude will ask if you want to leave packages unconfigured first. Answer n to this. You should then be able to answer y to all following questions to downgrade the necessary packages and install Steam.

Once done, please be sure to go to "Steam" on the Menubar of the opened Steam Window and select Settings. Move down to the "Steam Play" tab and check the "Enable Steam Play for all other titles" box to on- and "Run other titles with: Proton Experimental".


52 posts were split to a new topic: Troubleshooting Installing Steam on Zorin OS 16

A post was split to a new topic: Steam has small font

I found this thread truly fascinating, and surprised I have missed all of it till today. I most certainly have something to add here. I am running on POP OS 21.04 on my main gaming machine. POP OS uses more Flatpaks then PPA standard installs.

When I tried to use the DEB version of Steam, downloaded from their website, I was able to install it just fine, as well as launch Steam. However, I ran into issues trying to launch games from within Steam.

When I went to launch Steam via terminal, and then tried to launch a game, I looked at the Terminal window, and I had pages, upon pages, upon pages of errors of just about everything you can imagine, one of them being GLIB errors.

It left me under the impression that Steam, was missing many library files. But when I went into Synaptic, I wasn't able to find any libraries associated with Steam, that I could install. So I simply just gave up and returned to Flatpak.

So what started all of this process you ask? Well, I wanted to add an external drive to Steam, but Flatpak couldn't see the /mnt directory, and standard DEB installed Steam could. I was forced to return back to Flatpak.

And unlike the DEB installed Steam, or normal Steam I guess you could call it, which couldn't launch a single game if its life depended on it, Flatpak could. I just had to figure out the issue of getting a darn Flatpak to see a root directory.

Click this link to learn how I managed to do this...