Installing the .NET framework fails in Zorin OS 17

Good morning.

I'm new in Zorin OS, and I installed Keepass 2 program to manage my passwords, but when I try to use it, this advise appear:

"A newer .NET Framework is required".

I tried to install .NET framework directly from Microsoft guide (Instalación de .NET en Debian - .NET | Microsoft Learn) and every command worked perfectly, but the advice is still appearing. Please, can you help me to make it work?

I really want to work with Zorin OS but I need Keepass2. Please, ask me if you need some extra information.

Thank you in advance.


How did you install Keepass? I'm not finding it in the Software Store.

As for .NET, Zorin OS is based on Ubuntu 22.04 so you'd need to follow these instructions:

Make sure to use the tabs at the top to select the appropriate version of .NET that you need, in case version 8 is not suitable (I haven't checked which one KeePass2 uses), but this one installs fine.

Good morning.

I downloaded the software from this link, Debian -- Details of package keepass2 in sid, this is the link that Keepass2 recommends. I'm going to follow your guide, and if it doesn't work, I will post the update.

Thank you in advance.

The KeePass2 documentation page suggest to install this package using APT. You can easily do this by running:

sudo apt install keepass2

This will give you the appropriate package, tested and compatible with your version of Zorin OS. The link you shared is for Debian Sid, which is the development version of Debian and thus uses different library versions than what Zorin OS supports. This would explain the error message you received.

As an alternative, I would suggest trying KeePassXC. It runs natively on all Linux, MacOS and Windows and supports the same database format as KeePass2 so you could migrate all your passwords without issues.

sudo apt install keepassxc

Good afternoon again.

Is correct, .NET is not needed for "basic" Keepass install, but is needed for one plugin I use to sync my database file with my cloud provider called "Keeanywhere", and this is the software which needs the .NET framework.

Screenshot from 2024-04-22 17-18-46

This error appears when starting keepass, but is not problem of Keepass, its problem that this plugin doesn't the .NET framework installed as the newer one.

By my side, I tried to follow the steps of installing .NET framework you sent to me, but they where exactly the same commands I execute, and all softwares are properly installed and update, but the error is still appearing. I attach the outputs:

aspnetcore-runtime-8.0 is already the newest version (8.0.4-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dotnet-runtime-8.0 is already the newest version (8.0.4-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dotnet-sdk-8.0 is already the newest version (8.0.204-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Do you know what the problem could be? I need help to use Keepass2 and its plugin.

Thank you in advance.
Best regards.

Looking up that plugin, it looks like it may not be compatible to run on Linux at all. There's an open issue in their log since 2016:

If you can disable this plugin and launch Keepass without issue, then it's most likely this one plugin having trouble. In that case, I would raise an issue with the developers directly in case they, or someone from the community, can provide some workaround for this.

1 Like

Thank you so much, I'm going to contact the developers, lets try to implement this module in Linux too!!!

1 Like