Installing the WhiteSur GTK Theme has replaced the activities icon of the default zorin themes

Hi, I recently started experimenting with themes after having a look through some of the customization showcase threads and have tried a few so far without issue, including Yaru, Nordic and Orchis, however the WhiteSur GTK theme, installed using the installer script from their github hasn't. The theme installed correctly and I was able to enable both the shell and application themes alongside an apple styled icon pack in Gnome Tweaks, however disabling the theme and changing back to any of the pre-installed zorin themes kept the activities button as the apple icon installed by the WhiteSur theme.

The apple icon activities button persists on all themes that don't change the activities button and is changed correctly on those that do such as Orchis.

I am able to run ./ - i to change the icon for the WhiteSur theme, but the apple icon still remains when using any other theme that should have the default activities.
Even after running the uninstall script ./install -r The apple icon persists.

I've tried searching for the image in files, searching for activities.svg, using czkawka to find all similar images and have had no luck. And yes i've tried turning it off an on again haha.

I'm a linux beginner and at this point I'm all out of ideas for how to remove this image, so any help/ideas would be really appreciated.

If you use the Layout application and change it to something else does it still stay?

Also I have definitely took the activities SVG from the Zorin themes and applied it to other themes.

Zorin theme files are at usr/share/themes

But if it isn’t changing when you change themes I’m not sure where you would even put it.

Unfortunately all layouts (except the windows xp style, which I don't think has the activities button) show the icon.

usr/share/themes shows the proper activities svg files

That is so odd how it is overriding the file from the theme. As a temporary fix you could remove the activities button from the panel just so it doesn’t look so out of place.

Did you try selecting a different Zorin theme in the Layout application?

I’ve never seen any setting/theme element stay after changing layouts/themes

Someone else will hopefully come along with some other helpful advice.

On the Github page, read here:

Are you using the Dash To Dock extension ?
Or the default: gnome-shell-extension-zorin-dash

I believe this may be where the change was made by the theme installer.

I am running dash to dock, but it was not changed.

To check I ran the ./ --dash-to-dock and it installed it for me. Looking in the dash to dock folder, the only change is to the stylesheet.css file.

Uninstalling the dash to dock theming with ./ --dash-to-dock -r kept the apple icon in-tact.

Replace WhiteSur assets icons with the Zorin one should do it.

I have tried that, but the only result is the WhiteSur themes now have the Zorin activities assets. As far as I can see, there are no little apple logos anywhere on my computer at this point.

@Aravisian could this be the default (fall-back) icon was modified by the theme? I remember you mentioning it before and wonder if checking that would be if some help?

Problem solved!

Thank you everyone for attempting to help me, turns out, it was just a combination of not being super familiar with the ins and outs of linux, command line programs and slightly unhelpful command outputs and documentation.

Here's a run down of exactly what happened, and how I fixed it:

First I cloned the repository (this is based on my actual command history, not just memory), changed into its directory and ran ./ Unfortunately I didn't realise I was supposed to type my customisation choices before running the command, and moved on to ./ to customise the theme to my liking. Learning from past mistakes here I ran ./ --help to learn the options first. Using this I was able to connect it to firefox, add flatpak support, and install it for GDM. I wasn't sure what GDM was, but a quick google informed me it was the login screen.

Forgetting about this specific choice, one I changed back to a zorin theme using Gnome Tweaks, I was shocked to see the Apple activities icon still present (I later, as in today found out that the accent colour, some fonts and the x button in the activities view were also changed, but these were a lot more subtle). My gut reaction to this was to run the scripts again, searching for any uninstall option. Both scripts told me I could, however the option's description led me to believe it would completely remove everything, but it only removes the selectable themes.

./ --help
  -r, --remove, -u, --uninstall 
 Remove all installed WhiteSur themes. 
./ --help
-r, --remove, --revert 
Revert to the original themes, do the opposite things of install and connect. 

./ --help
-r, --remove, --revert
Revert to the original themes, do the opposite things of install and connect.

I did attempt the same with ./, removing the firefox and flatpak support, but, having barely interacted with the login screen, completely forgetting that I had even installed it. It only became apparent what had caused it when I realised that it was a change at the system level, and the GDM option was the only one requiring sudo.

But why did the GDM theme replace my activities icon? I have no idea. I assume it's a bug of some sort.

In all honesty, if the script reported on what was currently installed, either in general or just when attempting to uninstall it I would have been able to troubleshoot this problem days ago. Or, if the language used by the uninstall descriptions was clearer that might have helped me solve this issue. I later discovered that the Github page actually has far better uninstall instructions
image, and just running these commands would have solved my problems entirely.

Lessons learned? - I am personally safer just sticking to gnome tweaks level themes, rather than install scripts and that --help can sometimes be more of a hindrance than seeking out better documentation on github or elsewhere.

TLDR: Beginner mistakes, slightly obtuse language and a bug? is what caused this.

Anyway, thanks for the help and for reading I guess. Hopefully if anyone else is ever in this situation this can help.

1 Like

Darn, I should have thought to take a better look at the uninstall script myself. I will remember this for the future.

Really glad you got it figured out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.