Installing Zorin OS Acer Aspire E5

So, my Acer Aspire E5 had Windows 10 on it, so I tried to replace it with Zorin OS Core 16.1. I configured Secure Boot and everything, I tried legacy boot, but still no hope. It installs successfully, but says no bootable device found on startup.

Any help would be greatly appreciated, I can provide pictures and more information when I get home.

Did you disable Fast Boot or Fast Startup on Windows 10, first?
Windows Fast Boot locks the drive, preventing any read / write access to it.

I didn't manually ever turn it on nor off, but if it's preventing disk modifications, why did both the 128GB OS SSD and 1TB data HDD erase successfully? Nothing appears on those drives in Gparted Live.

Should I reinstall windows 10 to disable it?

No, not at all. If the drives are erased, then there is no need.

The above is a second post - and a first suggestion of things to check.

I would suggest picking up at this point and running Boot Repair:

Ah yes, that was the tool I used to fix my school laptop after installing Windows alongside an existing ubuntu install, I've got the ISO on my main laptop so i'll flash it on a USB and use that when I get home.

1 Like

Nope, I get unable to do MOK or whatever.
I'm really stuck

MOK means that Secure Boot is enabled.
If you are replacing Windows and not using Windows as Dual Boot, then Secure Boot is utterly useless and should be disabled.
Secure Boot is for Windows, only.

Secure Boot is found in the EFI Settings, usually under Security tab.
Look for your computer manufacturers specific F key to tap to access EFI / BIOS Settings.

Yep, I disabled it, still no luck

Is this an nVME or eMMC SSD?
Have you re-run boot repair after disabling Secure Boot?
Do you have an EFI Partition on your drive? (You can check using the Try Zorin and gparted)

It's nVME, It also has a 1TB sata hdd for data

Had you checked if RAID or AHCI?

It's not either

I have tried re-creating the EFI partition, but that didn't work, I will try boot repair when I get home. I only just saw your edit.

Nope, it appears that Zorin OS just doesn't run on this laptop. I'm quite disappointed that I'm going to be using Windows again. I am thinking of returning the laptop.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.