Installing Zorin Pro on a Huawei laptop (Dual Boot)

I'm trying to boot from a Zorin Pro USB on a Huawei laptop but it will not do it. I have checked the usb does work on other computers and even used different USB drives. I have been in the bios and changed some settings but still not working. Any ideas pleas?

1 Like

Gday @kmm300418 , Welcome to the community!

Have you set your UEFI to boot from the usb stick.
Also look here for further help.

Direct link:

Hope this helps.

If you wish to run Zorin OS alongside Windows, you will need to disable "Fast startup".

Or please explain what the error is or what your seeing?
Do you wish to run both Windows & Zorin OS alongside each other (Dual Booting)?
what program did you use to create the bootable usb stick?
Whats the spec's of your Huawei Laptop?
storage size. SSD or HDD?
Graphic's ?

Thanks for your message.
Its a Huawei Matebook 13 ryzen 7

Machine Spec's


AMD Ryzen 7 3700U 4 x 2.3 - 4 GHz, Picasso-U (Zen+)

Graphics adapter

AMD Radeon RX Vega 10


16 GB


13.00 inch 16:9, 2160 x 1440 pixel 200 PPI, IPS




2 USB 3.0 / 3.1 Gen1, Audio Connections: 3.5mm


802.11 a/b/g/n/ac (a/b/g/n = Wi-Fi 4/ac = Wi-Fi 5/), Bluetooth 5.0


height x width x depth (in mm): 14.9 x 286 x 211 ( = 0.59 x 11.26 x 8.31 in)


Webcam: HD 720p

Additional features

Speakers: Stereo, Keyboard: Chiclet


1.31 kg ( = 46.21 oz / 2.89 pounds) ( = 0 oz / 0 pounds)

I used rufus. I do want to dual boot but it will not even recognise the usb as a bootable media. the usb works on other computers. I have disables fast boot.
the message it shows is 'system doesnt have any usb boot option. please select other boot option in boot manager menu.'
i think the only option in bios is uefi.

maybe where im going wrong is not to use rufus but to use belenaetcher instead?

RUfus is great,
BIOS & UEFI = the same (Just BIOS is on older pc's)
A lot of helper's will just say BIOS, ( i do also :slight_smile: )
SO in UEFI (As it's newish),, but I/We may say BIOS being lazy :slight_smile: .
OK the pc specs are great..

1st, (With the usb inserted into the L/T (Laptop).
Then start the pc into UEFI & look of "Boot order" or similar.
you need to place the usb device at the top of the boot order.
then save & exit UEFI, this should checking your pc via the usb stick to check thing's are ready.

Please follow the above link to disable Fast startup, this is in the Windows OS, This is different to Fast Boot in the UEFI.
heres the link again :slight_smile:

please tell us exactly what is happening if you still have trouble with the above suggestions.
We can do this step by step. :+1:

1 Like

Ok I used balenaetcher instead of rufus and it worked. Thanks for your help :grinning: :love_you_gesture:

1 Like

Great to see you fixed the issue.
Rufus is my choice (But it needs to be configured) & that can hard to start with as Rufus is defaulted for NTFS.
Anyway Etcher is normally a great & easy app to use, But we do see troubles with Etcher more than Rufus.
Enjoy the OS.
Zorin forum community!

I'll mark your last post as the solution :+1:

1 Like


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.