Installing Zorin Windows App Support - missing dependencies

I owe you an apology just as much. Yesterday was one of those days where everything that could go wrong - did. With Vigor. I was at wits end by the end of the day.

And this is a particularly frustrating issue. I have encountered this with other users before.
What makes this one so very frustrating is that according to Ubuntu, all regional servers are supposed to be up to date and contain all the same packages as the main server. And the Ubiquity Installer defaults to setting users up with their regional servers for sources.
The problem is...
Oftentimes, the regional servers are not up to date and are missing packages.
It happens time and time again... Due to this, on this forum, we have taken to ensuring that we advise users to switch to main server.

I have noticed that some users continue to experience the same troubles after doing so. Because the Gnome Application Software & Updates that they use to switch to main server will show that they did... but does not always actually change it in the sources.list.
It's like pulling teeth.

I am on the Main Server and when I run the above commands, either wine, wine32, wine stable or zorin-windows-app-support will install, no problem.
What you may do to help yourself out is start a New Thread on the Wine or Windows App Support installation and see if we can troubleshoot with a fresh clean start on checking the sources.list and packages.

You're so kind; there is no need for apology since you're work is as much hard that everyone knows here :heart:.

Sure I'll create a new subject soon.

btw shouldn't I create new topic with more accurate subject?

since the both problems with installation of php and wine were look the same as you can see from pictures:

The exact error is

E: Unable to correct problems, you have held broken packages.

You can get this error from any package installation that is missing a dependency. You can get (essentially the same error, though worded differently) on Windows OS or Mac OS, too.
So the best way to go is to focus on the Individual software that you are trying to install. It is exceptionally rare that a related problem interferes with two different packages.

I understand this is done in the cli... but how about synaptic for a possible fix? Download synaptic deb on phone, transfer to pc....gdebi install... fix- broken.

I didn't understand what you said but I did installed synaptic and this is the error shown there:

I did marked the zorin-windows-app-support and then click apply, it told me fix broken then i clicked on edit->fix broken ... and then this shown up.

Completely remove the broken packages. Then search those packages by synaptic and install (this will automatically choose the dependencies and ask your approval). Then install. You should be able to install php this way also.

Can you please try:

sudo apt --fix-broken install && sudo apt install lib32z1

sudo apt install -y zorin-windows-app-support

Well, we took one step forward, at least...
Let's make sure any old packages are gone to prevent conflicts

    rm -r .wine
    rm .config/menus/applications-merged/wine*
    rm -r .local/share/applications/wine
    rm .local/share/desktop-directories/wine*

sudo apt remove --purge wine && sudo apt autoremove

sudo apt-add-repository 'deb focal main'

sudo apt install --install-recommends winehq-stable


Please check your sources list.
You can do this in Software & Updates > Other Software tab.
A full screenshot of all sources can help...

Ensure you do not have More Than One Wine Repository Added.

(By the way... confusingly, your system says you already had Wine and POL installed... :neutral_face: )

yes, told you that was working before and its been installed when i first installed the os.

Sources looks right... This is madness...

sudo apt install --install-recommends wine-stable


sudo apt --fix-broken install

sudo apt install wine32 wine64

Ok it says "Wine64 is already the newest version"

I think this may be what is tangling everything up. Somewhere, somehow, wine files got corrupted.
So it is conflicting with what is installed vs. what is to be installed.

sudo apt --fix--broken install

sudo apt remove wine* --purge && sudo apt autoremove

sudo apt update && sudo apt upgrade

sudo apt install --install-recommends wine-stable -y

apt remove wine* didn't work so i did uninstalled these 3 manually:


Can you open Software & Updates and send a screenshot of the First Open Tab?