Installing Zorin Windows App Support - missing dependencies

Oh thanks I will not remove it;

Btw another problem just got to me and i think its because of that:

before i could easily double click on exe files like telegram and it would download some wine stuff for first time and then open in other runs, but now it says that have to install windows app support again and after downloading some it says package dependencies cannot be resolved! (should i make another topic for this?!)

Another user also had trouble with installing Zorin Windows App Support.
He found that even changing to Main Server in the Software & Updates app did not actually change him to main server.
In order to fix it, he needed to manually edit his sources.list to remove the regional id.
This is what I would try, in your position.

I did check that, that's not the case:

Yes! same thing happening again...

I'm going insane of this error ...

Did you add 32bit architecture, before running the above command?

No, just the one you gave me earlier

You might follow these steps to instead install Wine 6 or Wine 7:

I did try that but i guess something is wrong with apt

after another apt update:

sudo apt --fix-broken install

image

This is insane...

sudo apt install wine-stable && sudo apt install --install-recommends winehq-stable

with root

sudo apt --fix-broken install && sudo apt install -y wine-stable

image

Can you double check that in Software & updates under "Download from" you are set to Main Server?

yes i did test the commands with main server aswell

i guess its not about download

You are not the only person that has run into this problem with installing wine...
One of the recent ones learned that changing to "Main Server" in Software & Updates was not enough.
They needed to edit the actual sources.list file in /etc/apt to ensure all main universe repos were actually set to Main instead of their regional server.

its not about wine! if you see my most recent php installation was just because of this apt weird look,
however wine was working pretty good before php installed
so i think that library may was in use of both apps

We have just spent a large amount of time trying to get wine installed.
Wine is not installed. You are trying to install it.
It is not APT. It is not Zorin OS. It is not php.
It is most likely a Regional Server that is not properly configured and up to date. Which would explain why you struggled with php, too.
Which is why:
https://forum.zorin.com/t/help-cant-install-php/17514/30?u=aravisian

I will allow another user to step in and assist you in configuring your sources.list manually.
I did not spend such a large amount of my time trying to help a person only to withstand being snapped at.

1 Like

Well I'm sure you know so much more about such problems please take my apologize if I've been rude or unthankful.

I just guessed that maybe the problem is something rather than repository server, even that I always tried all of those commands in both way and I've been always changing it from exact sources.list file.

However I don't think anyone else would take this problem confusion here, I'll still may ask it in some other platforms later but if there was any help or answers it would be great and I'm thankful.

Again thanks for you're time, I've installed the php at least and this topic is already solved!