Installing ZorinOS on Mid 1998 toshiba

I have a Toshiba A45-S120, from Mid 1998 that I'm having trouble using the internet since it can do dial-up, is there a way or something to get on the internet wire-free? Thank you! :slight_smile:

The USB ports would be quite a bottleneck, given that they would be speed USB1...
You would be better off with the cat5 connection, I think.

It is a A45-S120, it doesn't have a CAT5 because I never seen one, and I don't know what it looks like. Also, the laptop has a DVD tray but the ZorinOS 16 installation disk failed to even boot to the "Try or Install ZorinOS" screen.

Labeled as Network Port:

I'd rather not waste my time connecting the LAN to the Toshiba, then having to go thru these out of this world silly steps. We now know Zorin OS 16 is too new, so I guess ZorinOS 6.4 or 7 will have to be done but if it needs wired then I guess that Toshiba is garbage, windows 98 setup told me !!FALSELY!! that I interrupted the installation and I didn't do a single thing with it. Not wasting my time going thru it, and finding it. If anything doesn't work, ZorinOS 5 or earlier (going back to 2009) is going to have to operate. Why? Because computers can last forever on new operating systems. Will have to talk to Zorin developers about it when I have time to do so, but for now let's try to find a way to get Zorin on to that 25 year old toshiba a45-s120 from 1998.

I would actually opt for Zorin OS 12.4 or maybe Zorin OS 15.3
Is the machine 32bit or 64bit?

The trouble with older versions is a lack of Modern Support on some packages, as well as deprecations, regressions and abandoned repositories. Getting everything to work on Zorin OS 6 would be next to impossible, in these times.
It can run fine for playing around with in VM for nostalgia, but not really possible to use as a daily driver.

A. 1998, 32 bit was moderately new back in the late 1990's. B. I checked Virtual Machine too, Zorin OS is not available and used Oracle. C. Zorin OS 5 with chrome is all I need, just to get on the internet.

Does ZorinOS 12.4 Core is compatible with the Toshiba A45-S120? ZorinOS 5 on balenaetcher failed, so we're trying ZorinOS 12.4 on mine now. ZorinOS 16.1 Education Lite is going to my other newer toshiba for a student of mine.

Without trying it out, I have no idea... :wink:

Well, let's experiment.

1 Like

It failed, so now what to do next.

Can you please elaborate?

Used balenaEtcher, took 30 minutes, failed, assuming it finished as I experienced it multiple times, went on my toshiba and it gave me like 10 to 20 lines of code and it made no sense to my reading. So, now I have no clue on what to do. Trying again, will likely give me the same error infinitely.

@MacOS , I realize that attempts that fail are very frustrating. However, any effort we make to help you must be matched by your effort to provide information that can be used to assist you.
A photo of the lines of code on that screen would work. Or relaying details of what you saw or read.
I can assure you that the effort we put in to help others can be quite extensive.

It seems likely to me that a 1998 machine is simply too old to salvage. Even if we can get it to accept the install of the OS, it will balk at any Modern Browser.
You may be able to get it to accept a browser like Pale Moon... Maybe.

One the lines said it had a Kernel Panic, and I can't remember all of it. I'll send one when I can right away.

I don't want to be a spoilsport @Aravisian knows there's no limit in my imaginationspower to all. But SSE didn't come out until 1999 and it's already difficult for some to find a browser that can do https and doesn't need SSE2. Pale moon doesn't work. It need SSE.

Nevertheless, here is a list of browsers:

Liste von Webbrowsern – Wikipedia

If that doesn't help, which I believe, try a proxy that makes the modern web possible for historical 'slide rules':

Warning, if you have internet you will have trouble even noticing this. Update links have not worked for a long time and installed browsers do not support https. That means the answer is ALWAYS no internet. But until recently Google had a page active that looked very old and gray without https. Maybe it still works: Google.com
Cannot be seen with modern browsers. I owe them that I even found out that I had internet at all.

Installing the operating system will work. Check the checksums, get the integrity checked and start with the first stable version of Zorin.

Good luck because you will need it. I could hardly imagine a difficult project.

1 Like