Intel Centrino Wireless-N 1000 not working, Wi-Fi Networks shows device not ready

The card worked after updating Zorin OS but only worked for about 10 minutes, not even long enough for me to enter my wifi pw.

Info below:

Using a Tosiba Dynabook T451-35DW - I think Noah made it when he had a day off from the arc.

raisa@raisa-dynabook-T451-35DW:~/Desktop$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
raisa@raisa-dynabook-T451-35DW:~/Desktop$ sudo modprobe -rfv iwlwifi
[sudo] password for raisa:
remove (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) && /sbin/modprobe -r mac80211
rmmod mac80211
rmmod libarc4
rmmod cfg80211
raisa@raisa-dynabook-T451-35DW:~/Desktop$ sudo modprobe -v iwlwifi
insmod /lib/modules/5.15.0-97-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/5.15.0-97-generic/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
raisa@raisa-dynabook-T451-35DW:~/Desktop$ sudo lshw -C network
*-network DISABLED
description: Wireless interface
product: Centrino Wireless-N 1000 [Condor Peak]
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 00
serial: 74:e5:0b:17:0b:cc
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.15.0-97-generic firmware= build 35138 1000-5.uc latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:32 memory:c0500000-c0501fff
description: Ethernet interface
product: AR8152 v2.0 Fast Ethernet
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:04:00.0
logical name: enp4s0
version: c1
serial: e8:9a:8f:b3:e5:4e
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=5.15.0-97-generic latency=0 link=no multicast=yes port=twisted pair
resources: irq:34 memory:c0400000-c043ffff ioport:2000(size=128)
description: Ethernet interface
physical id: 3
bus info: usb@3:1
logical name: usb0
serial: 26:dd:d7:1e:58:4b
capabilities: ethernet physical
configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.15.0-97-generic duplex=half firmware=RNDIS device ip= link=yes multicast=yes port=twisted pair
raisa@raisa-dynabook-T451-35DW:~/Desktop$ inxi -N
Device-1: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi
Device-2: Qualcomm Atheros AR8152 v2.0 Fast Ethernet driver: atl1c
raisa@raisa-dynabook-T451-35DW:~/Desktop$ sudo rfkill list
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

The card was working fine previously

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.