Intel Tiger Lake Sound Issues with Headphone Jack

Hi folks,

I've just installed Zorin OS on my new laptop (Huawei Matebook 14s - Tiger Lake CPU) and I'm experiencing soundcard issues. If I try to play sound through my laptop internal speakers, the volume is very faint however, if I plug any cable into the headphone jack on my laptop, I get the full volume from my internal speakers and no sound at all from whatever is connected to the headphone jack.

What's supposed to happen is the speakers are obviously supposed to work at normal volume and then mute when I plug something into the headphone jack, but this doesn't happen. I am at a total loss here. I'm sure it's a hardware issue and something to do with Tiger Lake but I have no idea how to fix it. I'd really appreciate some help with this.

FYI - I normally connect an external speaker permanently to the headphone jack. This works perfectly fine when I boot into Windows 11 on the same laptop.

Please let me know if there is any additional information needed. Thank you!

This appears to be an ongoing issue with that Notebook:

You may try the suggestion in the link above...

https://bbs.archlinux.org/viewtopic.php?id=272380

I'm sure you get the idea...
Some of the above suggest that the hardware is currently still unsupported. Many HW manufacturers are not cooperative with Linux. They do not release the drivers. Linux engineers must try working backwards to decode the drivers, then include them in the Linux Kernel.

1 Like

Having done some research, I suspect that you have a Conexant chipset for sound. Hoping this might be the solution (.deb package is what you need) and no guarantees!

Research: Huawei Matebook 14s headphone / speaker problem / Laptop Issues / Arch Linux Forums

2 Likes

Thank you for that suggestion. I tried to install those drivers but it seems to be failing. Maybe I missed something? Thanks!

Do you want to continue? [Y/n] y
Setting up alsa-driver-linuxant (1.0.23.1) ...
Building modules for the 5.13.0-48-generic kernel, please wait... done.
ERROR: Build failed. Please review the build log at /tmp/alsa-driver-linuxant.18
002.log
dpkg: error processing package alsa-driver-linuxant (--configure):
 installed alsa-driver-linuxant package post-installation script subprocess retu
rned error exit status 1
Errors were encountered while processing:
 alsa-driver-linuxant

Thank you so much for this. I really appreciate the effort! I didn't realise it was specific to my machine. I thought it was an issue with Tiger Lake chipsets specifically.

I'll have a look at the possible solutions and go from there. I'm really hoping it gets fixed in a kernel update soon though! Cheers :slight_smile:

I tried a search for this issue on Ubuntu 21.04 or 21.10... came up blank. This may not mean anything. But it may mean that you are right - a higher kernel may have a solution.
You could try installing the Liqourix kernel on Zorin OS to see if that helps you...

sudo apt update && sudo apt upgrade

sudo add-apt-repository ppa:damentz/liquorix

sudo apt update && sudo apt install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

1 Like

Thanks for that. I tried installing this kernel but it appears to be the same. Is there any way to verify what kernel is running in Zorin OS? Just so I know I did it properly. Thanks :slightly_smiling_face:

I would really, really love to get this fixed. It's soooo much better than using Windows 11. The most obvious difference is that the fan pretty much never comes on when I'm using a Linux distro, but is almost constantly on when using Windows for whatever reason. My laptop also wakes up randomly all the time on Windows whereas on Zorin, it's perfect.

Really hoping I can get this sorted. Thanks for the help!

I think I found the version. When I run uname -r I get this:

5.17.0-14.1-liquorix-amd64

If you are on the 5.17 kernel and no luck... I think the previous posts that suggested this is not yet fixed in Linux may stand.

1 Like