Intel Wi-Fi 6E AX210 160MHz Driver Error

@Aravisian So all the linux distros, rather it be Arch Linux or Zorin, all have the same base distro? Is it up to the distro to determine when the kernel updates happen and what kernel version to stay on?

What exactly makes a distro like Arch different than Zorin? I heard Zorin is Ubuntu-based, but does this just mean that the default packages are different (pacman vs apt, etc)? Or is there something more fundamental?

Since the kernel is a collection of drivers, that should mean that, for example if I'm running kernel 5.14 on one system (where the wifi driver works), if I install any other linux distro and upgrade to 5.14, the driver should still be fine and I won't have to worry about compatibility, correct?

For the Linux headers, what's the difference between the regular ones and the "generic" ones?

I decided to return the laptop, BUT I replaced my linux distro that I had dual booted on my desktop with Zorin! I'm still working through a few quirks.
Firstly, I have a triple monitor setup with a receiver hooked into my GPU to pass audio (running 2080 non-super). My receiver shows up as a 4th monitor, and sometimes the OS will put windows on that monitor. Is there a way to disable the 4th "display" but allow audio to be passed to the receiver? Also, one monitor is 4k, one is 2k, and one is 1080p (two 27"s side by side, one 24" on top)

All Linux distros are based around the unix-like framework and the Linux kernel. Some are based on the old Red Hat (Fedora), some are based on Debian. Others are based on a common distro that is itself based on Debian. For example, Zorin OS is based on Ubuntu which itself is based on Debian.

What makes Arch different from Zorin is a complex question and far more involved than just which package manager each uses. From Rolling release to Stable release, to whether you use systemd, sysvinit... It's far more involved than just listing a few packages. How they all mesh together comes into play, as well.
Installing the 5.14 kernel, for example, should work for the wifi just fine... generally... But it won't always work fine. The big distros must patch and adapt the kernel to each release of their distro, which is why we use the Canonical Signed Mainline kernel and installing a different kernel outside of that is risky.

The generic is the regular, but you also have HWE or DKMS... A kernel patched for working with hardware or with lower end hardware or that is patched to work with specific hardware.

It may be better to start a new thread with this new question. Whether you can pass sound through, but not video depends on several factors. If it is HDMI, then it depends on the HDMI chip. On some, yes - and on others, the chip is too simple to allow for that.

any update on this issue? I just got a new laptop (Framework), with the AX210 wireless adapter, and I'm get the same error... please let me know.

Can you please download the firmware:

It may take some time.
Once done, open terminal with keyboard shortcut ctrl+alt+t. Then paste each into it, one at a time hitting enter after each:

sudo cp iwlwifi-* /lib/firmware/

sudo rmmod iwlmvm

sudo rmmod iwlwifi

sudo modprobe iwlwif

i've followed those directions and still no luck... this is the output from dmesg | grep iwlwifi:
steve@steve-Laptop:~$ dmesg | grep iwlwifi
[ 3.993310] iwlwifi 0000:aa:00.0: enabling device (0000 -> 0002)
[ 4.001362] iwlwifi 0000:aa:00.0: api flags index 2 larger than supported by driver
[ 4.001375] iwlwifi 0000:aa:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version:
[ 4.001570] iwlwifi 0000:aa:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[ 4.029320] iwlwifi 0000:aa:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[ 4.183047] iwlwifi 0000:aa:00.0: loaded PNVM version 0x324cd670
[ 4.433653] iwlwifi 0000:aa:00.0: Timeout waiting for PNVM load!
[ 4.433657] iwlwifi 0000:aa:00.0: Failed to start RT ucode: -110
[ 4.433660] iwlwifi 0000:aa:00.0: iwl_trans_send_cmd bad state = 1
[ 4.637690] iwlwifi 0000:aa:00.0: firmware didn't ACK the reset - continue anyway
[ 4.649954] iwlwifi 0000:aa:00.0: Failed to run INIT ucode: -110

Not sure if this will be helpful or not. I just purchased a Framework Computer and it was the DYI one. I chose the Intel 6E AX210 No Vpro Wireless. Zorin OS 16 Pro did not work out of the install with my Intel Wireless. As I read a couple of items about trying to install code that would hopefully initialize it (this was gotten from the Intel Site) that did not work. The Kernel that my Zorin install was 5.11.37 if I am not mistaken, seems that version and 5.12 have some issues with the No Vpro. Suggestion was to upgrade the Kernel to 5.(something higher than 12). I have successfully upgraded to 5.14.9 and my Wireless works like a charm. So love the Zorin distro, have played with Linux since the late 90's, mostly Red Hat and Mint. This is now going to be my go to laptop, good bye Windows and Mac OS X! This was the site that gave me some help with the update of the kernel and the other is where I got the Kernel from:
cheers paj

1 Like

Thanks Paj! updating to kernel 5.14 did the trick!

1 Like