Intel Wifi 6 AX200 Slow Wifi Speeds

Hello Everyone,

I've observed a persistent issue with Intel's AX200 during my Linux experience, particularly in relation to slow speeds. A quick online search indicates that many others face similar challenges, and this has been quite discouraging.

For context, on my Windows 10 installation (Atlas OS), I consistently achieve speeds between 400-800mbps, and my Android phone reaches around ~600mbps. However, on Zorin OS, I'm only getting approximately 30mbps, despite subscribing to a 1Gbps service. I've noticed Zorin occasionally defaults to older Wifi protocols like Wifi 4, even though my router supports Wifi 6. I'm uncertain if this requires special drivers or if there's another solution. Now it's not too big of a deal but having my Upload Speed slashed when I'm a Cloud Practitioner can lead to me waiting an hour or more just to upload system images to AWS.

While I have a strong affinity for Zorin, it seems there are compatibility issues impacting my experience.

On an unrelated note, I had to recreate my account due to an issue where the Zorin Forums seemingly forgot my email, stating "No account exists under this email." Strangely, I could locate my previous sign-up email. This occurrence, while not a major concern, did affect my confidence in the platform. No offense intended, just wanted to share the experience.

That's a more recent thread about the AX200 and trying to get it working as well - there are some links to drivers and some things you could try. But, can't guarantee that it'll work, as many have been asking about this same card.. Some have gotten it working on other forums like AskUbuntu and others; some did not..

This person tried a few drivers offered by Intel and some other sources, as well as some kernels. The Intel forum post suggests trying the AX201 driver; as it may work. Especially with drivers, sometimes you do have to try a few and see which ones work - the Broadcom B43xx devices are a prime example of that. I don't know if that person has tried the 6.3 kernel as stated working with Kali, but that could be an option as well.

If you try any distros that do have working WiFi with your AX200 - take note of what driver / version is being used; might be able to just download the one being used working and apply it to Zorin.

While I understood Wifi 6 is new i really just need 5 but sometiems witbout reason it defaults to Wifi 4 or even 3, any idea why it does that ?

Im starting to think the router is limiting Zorin but I'm not sure its pretty new.

There are two settings that you could check --

  1. Connectivity Checking may be enabled, possibly limiting some things in the larger picture.

  2. Metered Connection may be ticked for the WiFi settings on your network. That would definitely drag down some speeds.

Just popped in my mind - not that either of them are enabled, just possibilities.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.