Intenet connection not working

Hi,
I'm having a problem with connecting to the Internet. Neither Ethernet nor Wifi seem to work.
I've installed Zorin OS 16.1 Core 64bit to a Dell Precision 7510.
I cannot update Zorin because of the missing connection.
I cannot activate wifi at all (the option is grey, I can turn it on because the button won't go to the right. It says, in German: "Kein Funknetzwerkadapter gefunden", "no wireless network adapter found").
When I connect the computer by Ethernet, I can ping for example zorin.com (0% package loss), but I cannot access the page (or any other page) by using a browser.
I've checked the UEFI, and I think everything is fine.
I have reinstalled Zorin twice, with the same result.
However, I have installed it successfully on another laptop (same model).
I checked whether the driver for the notwork-card is installed, and it is.

I'll try to include a screenshot of lshw -C network.

Does anyone have an idea?
Thank you!
EHugo

Please also post the output of

uname -a

Sure:
Linux lgw17-Precision-7510 5.13.0-30-generic #33~20.04.1-Ubuntu SMP Mon Feb 7 14:25:10 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Did you download the Zorin OS from the latest version (16.2 r-1)?

My uname -a:
Linux HP-Laptop 5.15.0-58-generic #64~20.04.1-Ubuntu SMP Fri Jan 6 16:42:31 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Your drivers are present and they match your current kernel. Updating the system may actually get things working - but you need net to do that...
Can you please run the editor:

sudo nano /etc/modprobe.d/iwlwifi.conf

page down key or arrow key to the bottom and add these two lines:
For 2.4ghz
options iwlwifi 11n_disable=1
For 5 ghz
options iwlwifi 11n_disable=8
Comment out the line for the band you are not using or only add the line for the band you are using if you are not interested in having the ability to switch between the two,
Once added, tap ctrl+x to exit the editor, the y key to say yes to save, then the enter key to save current configuration.

Perform a full reboot, then test connecting to your wifi.

What area are you in? It sounds like a possible dns issue, but it could be more local than that... have you enabled the firewall? If so, you will have to add rules for the software that needs internet access. You can test this by disabling ufw and attempting to access the internet. If it works, use the firewall manager to add rules (there is a basic set to get you started that will cover most software installed).

Another possibility is that your router could use a reboot.

If the network is greyed out, it may have the wrong driver in use. Have you tried using your phone to access the internet (tethered) and doing what is required(download drivers) to resolve the issue?

Hi @Mr_Magoo
I downloaded it before Christmas. However, it works fine on most of the other laptops we installed it on. (We have several laptops here, all of them the same model. It works fine on most of them, but not on all).

Hi @Aravisian
thank you for your help. I tried, but it is still not working.
In the file, I found the following entry (which I've now commented out, just to try):

Remove iwlwifi \ (/sbin/lsmod | grep -o -e ^iwldvm -e ^iwlwifi | xargs /. sbin/rmmod) \ && /sbin/modprobe -r mac 80211
Is that correct?

(Just to clarify: I added the changes you suggested. When wifi still didn't work, I commented out the lines I've cited, to see if that could help, which it didn't.)

Hi @337harvey ,
I'm in Germany. I also thought it might beb a DNS issue, but in that case I wouldn't be able to ping pages, would I?

I did not enable the firewall.

The router works fine with all the other laptops (we have installed Zorin without a problem on 16 other laptops, and we have this problem with 4 laptops. They are all the same model)

I checked the drivers: They are the ones that you can download on the Intel homepage, and they are in the correct file.

ICMP traffic is different from loading pages from HTTP(S), FTP(S) and other protocols. There is less information and is used to check connectivity.

Though they are United States based, they have DNS stations world wide. You can search cloudflare DNS IPs for your area. They have better performance than Google.

This may be a router issue (try rebooting it), ISP line issue, limited DNS servers due to maintenance or hardware failures and many other possibilities.

Rebooting your equipment is the least you can do on your end. If it improves after reboot, it was your router or modem. If it doesn't, we can look more at your configuration to see if there is something else you can do to resolve the issue.