Internal drive is seen as a REMOVABLE drive ... help, please

Hi, everyone. This is a follow-up post regarding another post I made earlier about my hard drive setup (one primary and another as a storage drive). (Click here for the earlier post and subsequent thread.) I will make this post short.

Right now, the storage drive (secondary internal drive) is being seen as a removable drive. How do I stop this? How do I make it so that Zorin OS sees the secondary drive as a bona fide internal, non-removable drive? Thanks to everyone.

Even though the drive is internal in your computer, it is mounted as a removable device as it is not the drive containing your primary operating system in use.

Mounting the drive is primarily an organizational process and should not affect speed or operation.

Very interesting. And this is normal for Linux?

Yes, it is. Having the drives mounted but removable is a security feature, not a bug.
It is more to do with organization and labeling, as mentioned above. This is how AHCI (Advanced Host Controller) works and it is the same on Windows OS. Windows OS, however, will automatically mount the drives and display them with a Drive letter without showing the option to disconnect them.

Thank you very much. Learned something new.

So did I, actually. I had thought Windows OS also shows the option to click and disconnect the drive. I was surprised that it doesn't, since that is the Host Controller that performs the action (Motherboard).
This may be a feature Windows OS needs to add.

1 Like