Internal mic does not work properly with chat apps

Hi, I have a strange issue with internal mic of my lenovo ideapad310 laptop. This mic works with no promlem on windows 10.
It woks very well when I use the sound recorder. But when I want to chat with skype or google meet the other person could not hear my voice. I used test audio of skype and google meet and I found that my voice quality is terrible there. The voice is too low with some noise.
I have installed alsamixer and here is the information that it shows:

And here is more information from the terminal by some commands.

			sudo lspci -knn | grep Audio -A3
			00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d70] (rev 21)
				Subsystem: Lenovo Sunrise Point-LP HD Audio [17aa:3815]
				Kernel driver in use: snd_hda_intel
				Kernel modules: snd_hda_intel, snd_soc_skl
			00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
			sudo cat /etc/modprobe.d/alsa-base.conf 
			# autoloader aliases
			install sound-slot-0 /sbin/modprobe snd-card-0
			install sound-slot-1 /sbin/modprobe snd-card-1
			install sound-slot-2 /sbin/modprobe snd-card-2
			install sound-slot-3 /sbin/modprobe snd-card-3
			install sound-slot-4 /sbin/modprobe snd-card-4
			install sound-slot-5 /sbin/modprobe snd-card-5
			install sound-slot-6 /sbin/modprobe snd-card-6
			install sound-slot-7 /sbin/modprobe snd-card-7
			# Cause optional modules to be loaded above generic modules
			install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
			# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
			install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
			install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
			install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
			install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
			# Cause optional modules to be loaded above sound card driver modules
			install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
			install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
			# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
			install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
			# Prevent abnormal drivers from grabbing index 0
			options bt87x index=-2
			options cx88_alsa index=-2
			options saa7134-alsa index=-2
			options snd-atiixp-modem index=-2
			options snd-intel8x0m index=-2
			options snd-via82xx-modem index=-2
			options snd-usb-audio index=-2
			options snd-usb-caiaq index=-2
			options snd-usb-ua101 index=-2
			options snd-usb-us122l index=-2
			options snd-usb-usx2y index=-2
			# Ubuntu #62691, enable MPU for snd-cmipci
			options snd-cmipci mpu_port=0x330 fm_port=0x388
			# Keep snd-pcsp from being loaded as first soundcard
		options snd-pcsp index=-2
		# Keep snd-usb-audio from beeing loaded as first soundcard
		options snd-usb-audio index=-2

I don't know if this will help

But what I do is install pavucontrol sudo apt install pavucontrol, after the installation I open that and on the las tab "configuration" I select the "stereo duplex" option.

Then in the tab of the input devices it should show the microphone and you can configure easily the volume there.

For the noise I use a pulseaudio module, to "install" it, modify the following file; /etc/pulse/

At the last lines you should see a line that say
### Modules to allow autoloading of filters (such as echo cancellation)
And after that there is a some modules auto loaded, add a new line:
load-module module-echo-cancel

To finish, restart your pc and try your microphone

1 Like

Thanks. Unfortunately this solution does not work.

1 Like

Wow. Thanks a lot that solution works.
I edited this file /etc/pulse/ as described there.
And this is how my input devices look like:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.