Internal Microphone Not Working

Yes. I set Internal Microphone to capture. Didn't work.

1. Run ``alsamixer``

2. Goto capture channels (press F4)

3. Set the "Digital" Channel to a non zero value (e.g. 40). This is slightly non-intuitive but it seems necessary for anything from the internal microphone to be captured

4. Set Internal microphone as a capture device (select the channel and press the spacebar).

5. Set the "Capture" Channel to a non zero value (e.g. 40)

Beyond that, I do not know. I am woefully unqualified on Sound and Mic.
Perhaps Zabadabadoo may be able to help you when he logs in.

1 Like

@Aravisian Okay. Thanks for your help so far. At least I now know that my laptop detects my internal microphone.

@zabadabadoo Any help on this is very much appreciated.

@capriciousduck I think I can help you. I solved my issue by digging deeper into alsamixer. Try this:

  1. Type alsamixer on terminal
  2. Press F4
  3. Press F6 and there select default:1
  4. If you see something like this:

    Set Mic Boost to 100 and all Input sources to Internal
  5. If you see
    On step 3 after pressing F6 select default:0 and follow step 4 instructions.

I hope it helps :smiley:

1 Like

Hello, I have Mic and Internal Mic. Which do I set to 100?

Can you show screenshot?

Sorry. I forgot to include the screenshot. Please see the image.

Try to set Mic to 100 and then test your microphone

I did. Doesn't work.

Can you screenshot output after clicking F6 in alsamixer?

Here it is:
Screenshot from 2022-01-07 17-08-19

Can you post screenshots after clicking F4 of 0; 1 and (default) entries

Screenshot from 2022-01-07 17-49-55

Screenshot from 2022-01-07 17-50-47

In alsamixer
Hit [F6] and select "HDA Intel PCH"
Then hit [F5] and post a screenshot of All cannels Playback and Capture.

Whilst you are in there.
Unmute each channel by hitting "M" and set all channels to 100% as experiment.

Also check if you have [Auto-Mute] Enabled and try setting it Disabled.

Here is the screenshot:

Did you try setting Auto-Mute channel to "Disabled"?

I have no idea what [Inverted Internal..] channel represents. You could try playing with that i.e. Unmute (if it is muted. that is unclear) by hitting "M" and set to 100% as experiment.

I think Aravisian fairly summed it up in his post #7 i.e. "You are not alone in this with that hardware:" Trouble is, evan after some websearches, I cannot see a solution.
You may have to consider using an external microphone.

Okay. I'll look for a good external microphone. By the way, do you know one that works well?


Marked solution. 105

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.