Internal wifi not showing up or working in Zorin

This probably has been a problem already in this Forum. I can only get my wifi working by placing a dongle in a usb. I know the internal device is realtek so not expecting too much. I have the terminal command output 'lshw -C network' from a twin pc running Mint that I did have a problem with in kernel 5.15 and went to 6.2 to fix it, but that broke other things, but that is another battle. Anyway, output is:

frank@frank-Default-string:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: Realtek Semiconductor Co., Ltd.
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
logical name: wlp1s0
version: 00
serial: 78:8a:86:3d:ae:0e
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtw89_8852be driverversion=6.2.0-37-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:148 ioport:4000(size=256) memory:80600000-806fffff
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: enp2s0
version: 15
serial: 68:1d:ef:34:d6:56
size: 1Gbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=6.2.0-37-generic duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.0.110 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:17 ioport:3000(size=256) memory:80504000-80504fff memory:80500000-80503fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

See if the solution with 2 votes and a tick in this askubuntu thread sorts you out:

What is your output of sudo dmesg | grep -i 8852be?

Just if you need / want:
https://github.com/HRex39/rtl8852be?search=1

That's a driver for the card, if you need - looks like it's not being loaded by 'firmware=N/A' in your output. If so, you'll have to install the driver (per instructions):

git clone https://github.com/HRex39/rtl8852be.git -b dev
cd rtl8852be
make -j8
sudo make install
sudo modprobe 8852be

Also - do you have Secure Boot disabled in BIOS? Double-triple check..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.