Internet connection issue (new computer, fresh "Core" install)

Hello,

I've just installed Zorin OS 16 Core on a new computer (Z690 Edge + 12600k) only to be stopped by a constant lack of internet connection. Can't do any updating because of that - even inxi won't work because it needs some downloaded files to function (lang files etc). I'm running my usual connection via ethernet cable (its acknowledged by mobo) and tp-link model TD-W8960N (works fine on a different machine with win7 installed). I have turned on wi-fi and installed antenna to give myself an alternative path but Zorin is not seeing that either. It generally looks like missing drivers but i have no idea what i'm talking about really. My last Linux adventure was Pardus, like 10 years ago.

Sorry for bothering you with this problems of mine :].

Does

sudo lshw -c network

show the wireless device?

lshw

it's all its saying :]

Using your Hardline cable connection or your phone as hotspot, can you try:

sudo apt install linux-modules-extra-5.13.0-40-generic

sudo apt update && sudo apt full-upgrade

OS is not seeing any of it. No wifi, no network. It's quite weird. As of matter of fact enough weird for me to test it. I've installed windows 10 to get its point of view. It said that network card is absent and since that's not the case it means that drivers are missing. BIOS was updated so that's that. I can't link with internet on my new build but i can on the old one and have pendrive ready to go. "install linux-modules-extra-5.13.0-40-generic" leads somewhere, full-upgrade as well. Is there a way to download all that onto pendrive and install it from there?

ps. tethering not working - no device was detected.

Hmmm... Have you tested the card itself for faults?

Yes, though I do not know (and have no way of knowing) which updates you need...
If we could identify the Wifi Radio Card - then we could focus instead on the Drivers for it.

Its rigged with mobo - MPG Z690 EDGE WIFI
WiFi/Bluetooth = Intel® Wi-Fi 6E module
LAN = 1x Intel® I225-V 2.5G LAN
(LAN's enabled in BIOS)

I've tried tethering (again) with the phone (phone did not found anything to link to), linking two computers via ethernet cable (nothing happened) and all the usual jazz. Eh, it's the outcome of having everything online; sure its convenient but only if one have working internet connection which is a double edged sword.

Was silent lately because i was getting tl-wn725n wifi usb device since it was supposed to be working oob with linux(es) if version greater than 1.0. I've got version 3.0 only to find out that its not working (not found by computer). I need updates, no doubt, possibly different kernel version and don't know how to tackle all that :].

It is a catch-22, isn't it? You need internet to fix the internet...

Using another means, can you grab this driver for your tl-wn725n:

Once you have installed it (The install instructs. are on the github page, but it should just be the usual ./configure - make - sudo make install), you may need to blacklist the previous driver and remove the module:

sudo -i

echo “blacklist r8188eu” >> /etc/modprobe.d/blacklist.conf

modprobe -r r8188eu

Yes, it exactly has "sudo make install" as installation guide. Which tells me absolutely nothing - like i've said before my linux experiences are quite old and to be frank i have very little memories of operating terminal. I know where to find it and the gist of it but that's it. "make install" specifies nothing hence nothing happens. I'm guessing that terminal needs to be opened somewhere specifically and then maybe this install command will perform its wonders :]. All i was able to accomplish is cloning rtl8188eu repo and moving it via usb. Maybe too old for that stuff...

Exactly. :wink:
Right click within the directory that has the install.sh or the readme file in the driver you downloaded and extracted and choose "Open In terminal."
If your file manager lacks that option, you can use the cd command, then paste in the path copied from the pathbar of your file manager.

One step forward and two steps back it seems, because install command only gives me cannot stat ‘8188eu.ko’: No such file or directory info. I've looked into that and it seems that kernel headers must be updated first. Whatever that is...

[added]
found this tutorial How to Install Linux Headers without Internet on Zorin OS 16 • Installing • tutorialforlinux.com only i don't know what to download from Index of /~kernel-ppa/mainline I heard that getting too much may end up with unbootable system which i don't want :].

I do not think you need to install a kernel... Looking over the lwfinger driver, it may be that the syntax for recognizing the kernel needs to be changed.
To make things easier - you may just opt for a different release of the driver that does not need that fix.

Download and extract the file and save it in your Home Directory (Just to make using the terminal easier).
Once extracted, open terminal and change directory (cd) into it

cd rtl88x2bu

Now, this complicated command that neither of us would have up and figured out on our own is to help the package version align to DKMS (Dynamic Kernel Module Support):

VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)

The rest are a few more complicated install commands.
99% of Linux Installations are much easier than this. Point and click stuff. Just a bit of bad luck on your fresh start that you happen to have a Wireless device that needs a lot more work to get things going:
Reference it:

sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}

Use DKMS install

sudo dkms add -m rtl88x2bu -v ${VER}

sudo dkms build -m rtl88x2bu -v ${VER}

sudo dkms install -m rtl88x2bu -v ${VER}

Use Module Prober to direct the system to use this newly installed driver

sudo modprobe 88x2bu

Reboot and test...

I appreciate the help. Maybe i was unlucky with these technicalities but these things are logical - cause & effect - everything can be work out :).

About procedure... Both dkms's build and install commands are giving back this information:
er1

The kernel may be too new...
We can try installing the 5.8 LTS kernel (don't worry, this is safe)

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Once installed, restart the computer. When you see the Motherboard splash screen, begin tapping the esc key if you are using UEFI or the Left Shift Key if you are using Legacy (MBR) boot.
This is to bring up the Grub Menu - the one that offers what you are booting into.
If you are dual booting Zorin OS with another OS, then the Grub Menu should automatically appear at every reboot.

Select Advanced Options for Zorin and arrow key down to the option for Zorin on 5.8.0-63 and tap the enter key.
You should now boot into the 5.8 kernel. You can double check to be sure by opening terminal and running

uname -r

Test installing the Wifi Driver...

Weird things happened... I was trying to install 5.8 kernel and failed miserably because lang files were missing. I was hoping that important files were installed either way and moved to the next stage - the grub menu. It was loaded in its dos-like form so i was playing around with possible commands and resetting a lot until grub finally was displayed as os list. There was no option for 5.8 kernel in there - it was not installed at all x]. Had a few options there but all of them were based on default kernel. I've clicked one of them randomly really - just for the hell of it - and boom, logonui looked different - resolution that is. Logged in and found out that bluetooth and also wired network were available. I've installed ethernet cable and wham - connection finally was acknowledged.

I have quickly copied sudo apt install linux-modules-extra-5.13.0-40-generic & sudo apt update && sudo apt full-upgrade commands to the terminal and downloaded all that is needed. Don't know if this is enough but right now i'm typing via new computer which is a huge progress :]. Still no wi-fi though. Stupid win10 sees that tp-link router of mine right away... Well, not that i care though, since ethernet is my thing.

Just a last question - sudo apt full-upgrade that's the most important thing to do, right?

I would like to Thank You, Aravisian. Without your help i would be stuck on the desktop :].

I would say it is, at least in this case.
One of the first things any user should do upon installing a distro is Update and upgrade.
We can continue to work on your WiFi if you like - just in case.
I perceive switching to Linux to be analogous to learning how to drive in an Automatic Car, driving one for years- then one day switching to a Manual Transmission car.
At first, it is unfamiliar. You find yourself having to think a bit more. But once you get the hang of it, it becomes second nature... But you also discover the importance of having fuller control. Especially in wet, icy or heavy traffic conditions, where those delays on when or even if the auto trans shifted can be untenable.

I would not switch manual gearbox with automatic, no way :]. Maybe because i only know how to use manual...

Will figure out this wifi eventually - its only an addition in my case, nothing more. Need to have problems like that to actually learn things :).

Thank You :).

1 Like