Internet disconnects on 2 dual boot pcs and doesnt on a clean install

Hi Ive really been over and over this searching everywhere but cant find any solution. Id really appreciate some help here. Ive installed the latest Zorin on 2 of out laptops as dual boot with Windows 10 and 11 and one as a clean install. The clean install has no problems but both Dual Boots are disconnecting from the internet every minute or less. Reconnects then disconnects then have to reboot. I assume its something to do with windows so if anyone can help please let me know. I was hoping to make Zorin our main operating software and load it on our last latest laptop but Im reluctant to do so until I can solve this. Can you please put it in layman's language or make it easy to follow.

What is the make and model of the laptop?

Welcome to the Forum!

Do You use Wifi or Cable Connection?

Sorry only just woken its early morning here. Its a Acer Swift 3. Its interesting that last night I did nothing at all on the older HP Envy that Im on now and the issue seems to have resolved itself. Early to say but so far fingers crossed. However the Acer looses the connection about every 30 seconds now. Its fine on Windows 11 (Hate all windows grrrrr). Ive rechecked it and actually its unusable in Zorin. Have to sort it somehow since its my wifes laptop...

Wifi Connection. Very difficult to use a cable. Windows (that I hate) is perfectly ok. I have tried turning of the windows network connection but still the same. As Ive said in my other reply its Acer Swift 3 (so only about 9 months old and in Zorin so far its unusable. Got to sort it. Dont know why but this HP envy im on now has no issues fingers crossed. Also loaded Zorin on my near new Lenovo last eveing and its perfect of course after i deactivated the BitLock.

Thank you for the welcome. Lunux and Zorin etc are a breath of fresh air. Goodbye Micro bloody soft

Hmm ... Maybe it is a driver Issue. did You checked if any Drivers are available? You can check this in Software & Updates in the ''Additional Drivers'' Tab. to come to Software & Updates open the Gnome Software Center and click on the Hamburger Menu button beneath the min/max/close Buttons. There choose Software Sources. In the opened Window look to the right. There should be the ''Additional Drivers'' Tab.

Again just woken. Yes it was something I was wondering about but only tried to find drivers online but none available. But Ill take your advice and try what you suggest. Ill let you know. My 3 three other laptops are working perfectly on Zorin. This is so annoying with the Acer. Dropping out now every 10 to 30 seconds. The only way to get it working even for a few seconds is to go and ignore the device (network card) then reload it. Again might last 3 seconds

I assume the Acer Swift 3 is Windows/Zorin17 dial-boot. You are saying no wifi with Zorin.
Is the wifi adapter switched on. ref: Enable or Disable Wireless Networking on Acer Notebooks - Acer Community

We have sometimes seen wifi and sometimes audio hardware bound to Windows, even when Windows not booted.
Is "Fast Startup disabled" on Windows Power settings?

Im sorry Im so long in replying. I am very keen to sort this. but time differences etc. Ill double check everything you have suggested. The internet is not disabled on the laptop. I did disable fast startup but as I will recheck. Its very strange. Two of my other three laptops are dual boot one with W10 and one W11 and one is a clean install on a very old Sony. They are fine. Im kind of lost at what next to do but Id love to solve this. Thank everyone for your help so far.

Just to recap... Its not that there is no wifi its that it connects to my wifi for maybe a minute maybe 30 seconds maybe 10 seconds then starts disconnecting then reconnecting in a never ending cycle. If you go to settings and forget the wifi connection and then reinstall it you may get a minute until it resumes the cycle

Fast Startup definitely disabled

Im almost out of options. I cant search for updated drivers since the Laptop disconnects so frequently. I do have a D-Link DWA 192 USB Adapter/ Anyone know if you can use this with Linux and if so can someone let me know how?? Sadly nearly at the point of giving up with Zorin on the Acer. Would loading Ubuntu be any different?

I see from websearch using "D-Link DWA 192 USB Adapter ubuntu" that D-Link 192 drivers are only listed for Win and Mac. Maybe if you can see which chipset it has you can hunt for a driver based on that.
Example re 181 adapter: wireless - How to install driver for D-Link DWA-181 AC1300 Wifi USB adaptor? - Ask Ubuntu

You may wish to do more websearching yourself, considering Z17 is based on Ubuntu 22.04.

Possibly. The idea of using a live USB is to test out the "live" environment to determine if the OS will work on your system. Did you try to Zorin live USB? I would suggest download the latest version of Ubuntu 24.04 and test it out first with a live USB. That way you can determine if it will work with your hardware.

https://ubuntu.com/download/desktop?ref=upstract.com

Thank you for you help. I will try both options. Im not one that gives up easily but its getting to a point I cant think of what else to do. Ill let you know the results. Again thank you

Hi Guys, Problem solved. I completely removed Zorin and loaded the latest Ubuntu. Completely stable with no wifi disconnects. Unfortunately means Ill have to unload Zorin on my other 3 laptops and load Ubuntu to keep everything the same. Very frustrating but it is what it is. Thank you for your suggestions.

I am thinking, maybe a leter kernel (same as the later Ubuntu) loaded on Z17 would have worked for you.