Internet does not navigate Zorin pro17

installed Zorin pro 17 on a MacBook Pro early 2008
turned on wifi
choose my wifi and used correct password.
the driver is Broadcom 802.11 linux STA
DOES NOT NAVIGATE

Can you please connect using Ethernet or mobile phone hotspot tethered with a USB cable. Once connected to the net, in terminal run:

sudo apt install firmware-b43-installer b43-fwcutter bcmwl-kernel-source

Disconnect the Ethernet / phone hotspot and reboot.
Test wifi.

2 Likes

the wifi connect but does not navigate

I am sorry, but what do you mean by "does not navigate"?

faleiria@faleiria-MacBookPro:~/√Ārea de Trabalho$ lshw -C network
AVISO: você deveria executar este programa como superusuário.
*-network
descrição: Interface sem fio
produto: BCM4321 802.11a/b/g/n
fabricante: Broadcom Inc. and subsidiaries
ID físico: 0
informa√ß√Ķes do barramento: pci@0000:0b:00.0
nome lógico: wls4
vers√£o: 05
serial: 00:1e:c2:c1:f0:5c
largura: 64 bits
clock: 33MHz
capacidades: bus_master cap_list ethernet physical wireless
configuração: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) latency=0 multicast=yes wireless=IEEE 802.11
recursos: irq:16 memória:d7300000-d7303fff
*-network
descrição: Ethernet interface
produto: 88E8058 PCI-E Gigabit Ethernet Controller
fabricante: Marvell Technology Group Ltd.
ID físico: 0
informa√ß√Ķes do barramento: pci@0000:0c:00.0
nome lógico: ens5
vers√£o: 13
serial: 00:1f:5b:ee:50:b6
capacidade: 1Gbit/s
largura: 64 bits
clock: 33MHz
capacidades: bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuração: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
recursos: irq:29 memória:d7200000-d7203fff porta de E/S:5000(tamanho=256) memória:d7220000-d723ffff
AVISO: a saída pode ser incompleta e imprecisa, você deveria executar este programa como superusuário.
faleiria@faleiria-MacBookPro:~/√Ārea de Trabalho$

with iPhone hotspot navigate www
with wi fi of mbp NOT
firmware b43 ok

You may have a Broadcom card that doesn't like the STA driver.

I've had two Broadcom cards, both 43xx's - one liked the STA driver, one liked the b43-firmware / b43-fwcutter packages. Same cards, just different runs.

with zOrin pro 16.3 b43 firmware functioned ok
with zOrin pro 17 b43 firmware does not ok

there is a question mark

You may need the STA driver.
I went looking for a guide - and came across this absolutely excellent and well detailed write up:

The above guide is very thorough.

1 Like

firmware-b43-installer já é a versão mais recente (1:019-7build2).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 n√£o atualizados.

I have been doing some websearches using " BCM4321 802.11a/b/g/n Ubuntu 22.04 Mac"
and found the same link as Aravision posted above, as well as this: WifiDocs/Driver/bcm43xx - Community Help Wiki

Maybe a temporary fix. As your Broadcom wifi worked OK with Z16 (but not Z17) perhaps try an older 5.15 kernel, as used in Z16.

2 Likes

I think that's the best doc for B43's - and have a BCM4321 in a Dell 1501 (Z15 Lite x32) too! Maaaany devices came with B43xx's. All the threads I've found say it's kinda in the air which one it likes though - picky lol Have experienced that as well; 18.04 liked STA drivers, 20.04 liked the standard b43-firmware / b43-fwcutter, non-STA - haven't tried 22.04 though.. but seemed to be different through the releases (Ubuntu and derivatives) :thinking:

The AirPort may have been facing Wi-Fi connectivity issues. Did you face this problem in macOS too?

Gday @faleiria
Try disabling the firewall on Zorin,
then Reset your modem.(disconnect all lines to modem for 1-3min's depending on age of modem)

Can you wifi with other devices, another phone?/computer?
( i see yes with iphone )

Note to helper's:
It seems the wifi is working.
User is getting internet/navigation, via iphone hotspot.
But not getting internet via home/landline modem.
further suggestions:
Update modem firmware & pc firmware.
any VPN?
Check ports being used.

hope these may help.

firewall disabled = persistence of question mark inside of wifi sign
firmware b43 does not solve question mark
with usb cable and celular navigate ok
actually the handshake between wifi board and router does not work
In zorin pro 16.3 worked with zorin 17 pro d'ont

@faleiria ,
Please run the following to see if this will start wifi.
first run

sudo modprobe wl

Then

sudo apt update
sudo apt upgrade
reboot

After reboot, Test wifi.

Still Not working?
Open the "Software & Updates", goto "Additional Drivers" & check for other drivers.

Just to test
Try setting your home/landline modem without Password,
If this helps,
Reset modem & re-configure your security & password.
Hope this helps.

In Settings>Privacy
Toggle "Connectivity Checking" Off then On

That fixes the wifi [?] issue whenever I see it on Z16.3 Core.

MY MBP PRO EARLY 2008 IS DEAD , so far so long!

Is it totally dead, as in no life at all, or just won't boot ZorinOS?