Internet goes out a lot

The internet goes out often on my computer but then works for a limited amount of time if I restart my computer before going out again and I think this is due to some bug in Zorin OS Ultimate because it never happened on my other operating systems before (Windows, etc.). Is there any way to fix this? I have tried many solutions. I have tried different settings, typed in many different commands into the terminal that others said might fix it, etc. Nothing has worked yet. Does anyone know what I can try? I have Zorin OS 15 Ultimate. Are there any simple terminal commands I can try that tend to fix this type of issue or no? Thanks in advance.

Down below are my specs in case this helps at all:

H/W path Device Class Description

                      system         Surface Pro 3 (Surface_Pro_3)

/0 bus Surface Pro 3
/0/0 memory 64KiB BIOS
/0/4 memory 128KiB L1 cache
/0/5 memory 512KiB L2 cache
/0/6 memory 4MiB L3 cache
/0/18 processor Intel(R) Core(TM) i7-4650U CPU @ 1.70GH
/0/19 memory 8GiB System Memory
/0/19/0 memory 4GiB SODIMM DDR3 Synchronous 1600 MHz (
/0/19/1 memory 4GiB SODIMM DDR3 Synchronous 1600 MHz (
/0/100 bridge Haswell-ULT DRAM Controller
/0/100/2 display Haswell-ULT Integrated Graphics Control
/0/100/3 multimedia Haswell-ULT HD Audio Controller
/0/100/14 bus 8 Series USB xHCI HC
/0/100/14/0 usb1 bus xHCI Host Controller
/0/100/14/0/3 input Surface Type Cover
/0/100/14/0/6 communication Bluetooth and Wireless LAN Composite De
/0/100/14/0/7 multimedia Microsoft LifeCam Front
/0/100/14/0/8 multimedia Microsoft LifeCam Rear
/0/100/14/1 usb2 bus xHCI Host Controller
/0/100/16 communication 8 Series HECI #0
/0/100/1b multimedia 8 Series HD Audio Controller
/0/100/1c bridge 8 Series PCI Express Root Port 3
/0/100/1c/0 wlp1s0 network 88W8897 [AVASTAR] 802.11ac Wireless
/0/100/1f bridge 8 Series LPC Controller
/0/100/1f.2 storage 8 Series SATA Controller 1 [AHCI mode]
/0/100/1f.3 bus 8 Series SMBus Controller
/0/1 scsi0 storage
/0/1/0.0.0 /dev/sda disk 256GB HFS256G3AMNB-220
/0/1/0.0.0/1 volume 511MiB Windows FAT volume
/0/1/0.0.0/2 /dev/sda2 volume 237GiB EXT4 volume

I did a search of "wlp1s0 network 88W8897 [AVASTAR] 802.11ac Wireless Ubuntu".
If you have already tried many things,I guess you may have done the same.
Without knowing what you have tried, maybe this was one of the things you found:

I have encountered the same issue on a similar setup. Have you tried turning WiFi optimizations off?
You can turn it off by

Chaning the value of wifi.powersave located in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf from 3 (enabled) to 2 (disabled).


Also this might sound dumb, but switch your bluetooth completely off and see if your WiFi keeps disconnecting again.

If none of the above works, could you please tell us what things have you tried yet?

You could alternatively contact the devs directly. As far as I know, the devs themselves provide support to Ultimate users.

1 Like

Thanks for the response. None of those solutions worked--how do I contact the developers exactly?

You can send a message through the contact form on the Main Page (clickable Zorin Logo on the upper Left of any Forum Page) or a Private Message from the profile of either @zorink or @AZorin

Thanks for reaching out to us @randomgentleman. We have recently replied to your email with the next steps to find the source of the issue and resolve it.