Invalid filenames during backup copying

Hello.
Recently switched to OS17.
Now I am seeing error halts due to invalid file and folder names in file copy operations. These are files I have been able to copy and back up for a decade. Sometimes removing a space at the end of the name fixes it. Sometimes I can't figure it out.
What is going on?. I am using NTFS formatting on my backup drives so any machine can read them.

Remove special characters from the file and folder names.

Why were these filenames good in the past with OS15.3 ?
I have been copying these files for a decade or more.

Have you run a S.M.A.R.T. test on the drive?

can you share a screenshot of the name of those files?

Yes, I tested and also reformatted the drives. Five different drives. I was able to copy all the files off the machine and back on for the OS upgrade. Problem started with making new backups with the new OS17.

Hi!

Have you tried performing the file operation on an ext4-formatted drive?

Thanks for the suggestion. I will try that in a few days when I have time to work on it again.

This is one;
Removing The Timing Parts | Audi A4 B5 2.8L V6 Timing Belt Replacement | Removal And Installation | | Happy Wrenching.html
another;
Ross-Tech: VAG-COM: Audi Service Interval Reminders.html
Seems like I have a hundred to edit.

Remove the |

Remove :


Here is the list of special charcters those need to be removed:

1 Like

Thanks for that list.
Are these rules universal rules or linux or microsoft? I have been able to use the blank space in filenames for years. I recall there were lot of limitations back in the DOS days. I have also used $ in my tax record files.

1 Like

I remember reading something about this while trying to mass rename 100's of thousands of music files.

The main difference between Linux and Windows regarding filename restrictions is their handling of special characters.

Linux allows most special characters in filenames, including spaces, but some characters such as *|* have special meanings in the command line and may cause issues if used in filenames.

Windows, on the other hand, has more restrictions on filenames, prohibiting characters like |, \, /, :, *, ?, ", <, >, and space (though I think it allows spaces at the end of a filename...).


In your case with the errors observed during a backup operation where there might have been illegal characters in the filenames, you can either rename the files to remove these illegal characters or escape them using backslashes \ when referencing them in commands, such as when a script tries to initiate the backup copy operation...

1 Like

I've noticed that for Folders and Files the best practice is:

A_timing_belt.html in folder Transmission_files.

It is also useful to limit as much as possible folder names as if it is needed to navigate in the terminal, if the folder were called Transimission files you would have to navigate to:

cd Documents

then

cd \Transmission \files

I only became aware of this when having to deal with pdf files when i was working from home.

I understand what you are getting at. I used to do that back in the DOS PC days. I don't ever handle files in terminal. I use the graphical file interface.
I didn't create most of these names. They came from where ever I download the files from.
It seems the rules are more relaxed with Linux. I like to have filenames that are descriptive and easy to read so that I can find the file a few years later if I need it.
I will have to study this more.

I formatted a drive ext4 and it seems to take the files. I see that the drive cannot be mounted by an old windows machine.

Windows can never read Ext4 FS, but GNU/Linux can read NTFS due to a utility that is now automatically present in most distributions, ntfs-3g.
If other computers need access or need for dual-booting I did a tutorial video here:

I gave the advice on terminal because if ever you need to work on pdfs that require OCR to be applied using the terminal application ocrmypdf, or need repairing with pdftk (pdf toolkit) then single name directories and files with underlines in their names are essential.

I had a system update yesterday. Now it seems that I can copy files with illegal characters in the filenames to an NTFS drive. The file manger strips out wrong characters automatically now. There must have been a bug fix.

Problem apparently solved. Thanks for all the help.

1 Like

Thanks for that. I just want to use NTFS just in case my Linux machines have a major failure and I have to use some Windows machine in a pinch. No other reason.