Invalid Partition Table on Zorin 17.1 install

About 30 years ago I wrote a specialized computer program to keep a database of family genealogical information. A few years later I gave the program the ability to create from the database information a web site with 2 or 3 web pages for each person in the database.

As I have updated the database over the years with births and deaths and new information discovered, the database has grown to include about 2,000 people and the web site produced now is about 5,000 web pages in size. I update the web site every few months to keep up with the growing database.

About ten or fifteen years ago I began to install various Linux distros on 512 Gb thumb drives and put the 5,000 or so web pages on the thumb drives. I could then give a thumb drive to various family members who were interested and they could use Firefox on Linux to access their family information. The Sandisk Fit thumb drives I use are actually only as big as the toenail on my big toe.

Anyway I have done this with Mx Linux and PoP OS and Zorin and lately Rhino distros of Linux and it has worked fine.

When Zorin 17 became available I decided to try it and downloaded version 17.1 and installed it on an old Dell Latitude E6430 laptop with a 500 GB hard drive to try it out. It worked fine. After I had set up the web pages on the laptop I used Clonezilla to duplicate the system on an old 500 Gb hard drive I had removed from another computer attached to the laptop by USB. That worked fine too.

So I formatted a 512 GB Sandisk fit thumb drive to duplicate the installation. My first problem was that Clonezilla refused to clone to the thumb drive because although I only had about 400 Gb of data on the laptop Clonezilla said that I was trying to copy a 500 Gb hard drive to a thumb drive with an actual capacity of about 464 Gb.

OK, I said. I'll just reinstall Zorin 17 on the thumb drive and copy the database to it. So I booted the laptop from a Ventoy thumb drive which contained all my linux ISOs including Zorin 17.1 and installed Zorin 17.1 on the Sandisk thumb drive. Zorin said the installation was finished and I could now boot from my new thumb drive. Alas, when I tried to do so on two or three different computers I would get the message "Invalid Partition Table" and I could not boot from the new thumb drive.

As far as I know, Clonezilla works by cloning entire drives. Even if you are not using all the data, the entire capacity of the drive should be considered.

If you plug this drive on another computer, can you see it when you launch Disks? Can you share a screenshot of that with this drive selected?

That's an unusually large amount of disk space for such as small amount of records, even after accounting for the OS and additional software installed :thinking:

The screenshot is attached.
You are right 400 Gb is a lot but the data I include for family members includes a lot of multimedia files both of family and other videos, pictures and audio files which I think might be of interest to family members in addition to the 5,000 web pages. Those web pages also include family multimedia files.

Also I just realized that in the original Zorin 17.1 installation on the laptop I am also getting the message "Invalid Partition Table" but I have just been pressing [ENTER] and Zorin goes ahead and loads. It does not do that from the thumb drive I created.

Most likely, the trouble is due to the BIOS needing update on the Dell machine.
You will need to download the latest BIOS and use a Windows LiveUSB to apply them:

After trying numerous times over a period of 3 days with a number of different computers I have concluded that Zorin 17 cannot be installed on a thumb drive and run successfully on another computer as Zorin 16 and a number of other distros can. I have discovered though that a clone of a successful installation to a hard disk drive onto an external hard disk drive can be attached by USB to another computer and runs fine.

If anyone decides to modify Zorin 17 so that it can be installed on a thumb drive please be aware that the major problem that I have had in doing this with other distros is the problem of MBR Vs. GPT vs. EFI. It seems that I can run the thumb drive on another computer only if the boot process is similar to that on which it was created.

I know this is a solvable problem because I have a Ventoy USB flash drive that will boot on any computer I have tried it on regardless of the booting process.

I can only think of this that may be used to help with this issue: