Is there a way to reset desktop/window preferences to install default?

I’ve been playing with the various desktop / windows settings to see what look and feel would please me best. All over a sudden, I recognized high CPU load and found xiccd to be the culprit using as much CPU as was available to it.

I suspect one of the settings I changed has triggered xiccd, since I didn’t notice that process before (I was debugging high CPU usage by firefox and web-content processes).

I’d like to undo all the changes, but can’t remember them all (too many different places to change settings). Is there a way to reset all the user’s settings to Zorin-OS’s default? This is Zorin Education Lite 32bit, if that matters.

See the last post here: https://forum.xfce.org/viewtopic.php?id=13309 - you can also kill it using Utilities -> System Monitor

For resetting, I don’t know if this works on XFCE (yours): https://www.omgubuntu.co.uk/2017/10/how-to-reset-ubuntu-desktop-to-default

Thanks. Did that already, but thais doesn’t solve the problem when is appears again later. I’m preparing this old T43p for my 9 years old grandson who doesn’t have Linux experience, yet. So I try get rid of any troubles as much as I can before handing over.

In that thread on the XFCE forum, there is a link pointing to a solution:


I’ll add a summary of the problem and quote a solution here for quick reference. Please read the whole thread if in doubt.

The problem seems to be that the process is not ending when the user logs out, and another xiccd will be started at the next login. The problem being the old process which is now hogging the CPU.

A solution seems to be:

Sounds easy to try.

I’ll try. But after reading the XFCE thread, I doubt changing the settings triggered this. I’ll have to see if above solution solves the issue.

Thanks for the quick reply. Much appreciated.

I think for XFCE you need to remove, or move the following folders…

  • ~/.config/xfce4
  • ~/.cache/sessions
  • ~/.cache/xfce4

Otherwise create a new user and delete your current user and it should create the account using the skeleton files.

I have implemented the KillUserProcesses=yes, and have not seen the high CPU usage for no reason anymore.

But thanks for the information, anyway.