Is Zorin OS causing harm to my system?

Hello,
A month ago I installed Zorin OS core to my system. It worked fine and I love it.
However, after a few days my laptop wouldn't turn on at all, I contacted the Dell support and send my system for a motherboard replacement. I just received my laptop, I updated the system to 16.1 and rebooted fine, except I closed my laptop without turning it off, and it won't turn back on at all, there is just the charging light on. I contacted Dell, did all the steps they asked me to do, but nothing worked. Therefore, they would replace the motherboard a second time.
But, I'm thinking is the operating system could cause those issues ?
Since, I did not have those problems before installing zorin os and seems like it might be the cause of that.

I just to want to know if Zorin OS can cause harm to my laptop ?

I'm using a Dell Insiron 5515.

Thank you

This sounds like it is not waking from suspend - and set to suspend when lid is closed.

If your Dell has an Nvidia Card:
Boot into Recovery Mode by tapping esc or Tab starting when you see the Motherboard Splash Screen.
Tap Vigorously.

Arrow key to boot Zorin in Recovery.
Arrow key down to Drop To Prompt
Hit enter
Run

sudo ubuntu-drivers --gpgpu install nvidia

sudo systemctl disable nvidia-fallback.service

sudo nano /etc/default/grub

Find the line GRUB_CMDLINE_LINUX="quiet splash" and add the following parameter nouveau.blacklist=1 to make it GRUB_CMDLINE_LINUX="quiet splash nouveau.blacklist=1"
ctrl+x to exit, then the y key and the enter key to save and exit.
Now, run

sudo update-grub

If you perform all of the above, but it does not work (You can restore grub to just "quiet splash" then run the following if using a driver higher than 470, which you very likely are:

sudo rm /etc/systemd/system/systemd-hibernate.service.requires/nvidia-resume.service

sudo rm /etc/systemd/system/systemd-hibernate.service.requires/nvidia-hibernate.service

sudo rm /etc/systemd/system/systemd-suspend.service.requires/nvidia-resume.service

sudo rm /etc/systemd/system/systemd-suspend.service.requires/nvidia-suspend.service

If this still does not work, then you may need to up to the 5.15 kernel, as there is a known regression in some of the 5.13 kernel versions that can cause this issue.
Which, we should try before trying to replace the M.B. again...

The problem is I can't boot in anything, Nothing is showing up.
And I'm using an AMD CPU/GPU

Hard shut down the computer. Then hit the power button. Are you saying that there is NO Motherboard splash, No activity whatsoever?

Yes, it seems.

This may have a cause other than Motherboard - like power supply. Can Zorin OS cause it? That is very unlikely. Hardware Components are not run or governed by the Operating System that you interact with. They operate, then communicate with your operating system by using Drivers.
Drivers are like Translators, providing definitions and terms and language.
This being the case, the Operating System, Like Windows or Zorin Or Ubuntu cannot break hardware because they cannot force it into a compromising operation.
Only the manufacturer of the hardware can provide such commands - and some have been caught doing just that, bricking devices in order to increase profits.

3 Likes

Thank you for the answer.

The Dell laptops have that bug functions you can repair that alone not sending to the service. You can searching on some Dell forum. I remember you need click some power more long to switch power on. This is some manufactured drivers DELL with battery and motherboard. The next issue could be if the battery is wrong for this model then motherboard could have problems with that - not correct drivers recognize from motherboard. Research and find some more information on this problem.
Here some example reparation Dell.

You can reading under a post what people talking, maybe little help find your problem.

Sorry for the late answer but I already tried everything that I could do.
Thank you anyways

It could be a tapes what are connected from motherboard laptop to the desktop screen monitor could be broken. If they working and they are short in some time they are just burst. This is popular problem in dell laptops.

The led that indicates the charging is not working, so it must be a problem related to power.

Did you trying another distribution Linux?

Yes before I tried several distros, I used Manjaro for few months. But it only happened with ZorinOS