Issue printing with my printer

Hi,
today I have been having issues printing with my printer. The printer has always worked prior to today.

I have tried deleting the printer and re-adding it, which zorin can do fine.

But it will still not print, when I look at the print queue it just stays permanently on processing the print job and never completes

I have a desktop connected to a brother laser mono printer.

My friends computer which I also support has a Dell laptop connected to an Epson inkjet printer, and has same issue, hers is connected by cable, but also will never finish processing the print job.

Do you know if there were any software updates immediately prior to printer not working. e.g. kernel updates?

I wonder if installing gutenprint might solve the issues?

I think there was some Zorin updates

Also the same brother printer works fine from a mac and my friends laptop with Zorin 16 was also printing fine with an old printer the day before hand, but wont print with the new one.

My home computer is connected wirelessly via localhost.

My friends laptop is connected via USB cable

Both show print jobs in the queue as processing but never actually print.

It never finishes processing so there is never any error mesage.

Tried installing gutenprint from the snap store and it wont launch

Okay

It must have been an update, could also be related to teamviewer which was also installed after last working print job.

so ran sudo apt remove teamviewer then sudo apt-get update followed by sudo apt-get upgrade

Deleted the printer from settings, restarted computer, added printer back again and it now all works.

2 Likes

Glad you got sorted. Remmina that comes with Zorin is ranked second and TeamViewer 6th when it comes to Linux.