Issue with displaying desktop

Hi guys,
I have installed Zorin 16 Pro, when I boot it, it will show the Zorin Logo along with ZORIN text then simply black screen, the funny thing is that when I try to login via VNC from another machine I can access the machine without any issues and I can see the desktop, login, and do whatever i want to but only through VNC, now that the machine is accessible via vnc I plug in the HDMI cable and again there is nothing, black screen...

How to solve this please

VNC may be using different graphics.
Are you using Intel or AMD Integrated or Nvidia or AMD Dedicated?

Thank you for your response, I'm using Intel Graphics

CPU: Intel i5-6260U (4) @ 2.900GHz
GPU: Intel Iris Graphics 540

You can access the Recovery Menu:
https://forum.zorin.com/t/how-to-enter-recovery-grub-menu-advanced-options-for-zorin/8001/2

Then at the last option on the menu, drop to Prompt.
Run

sudo nano /etc/default/grub

In the Editor, arrow key down to the line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

You can try Two Different things here to see if they help.
Remove the splash parameter:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"

Or
Add the nomodeset parameter:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

I suggest trying the Splash parameter removal first.

Once you have it as GRUB_CMDLINE_LINUX_DEFAULT="quiet", tap the keyboard shortcut ctrl+x to exit the editor. Tap the y key to say yes to save. Tap the enter key to save the current configuration.
Now you must run this command for those changes to take effect:

sudo update-grub

Proceed to normal boot and test.
If no good, try the Nomodeset parameter.

Thank you,
I have tried all those with no luck.
Now it became worse, I have set
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" and it's not booting and i can't access grub or boot menu or anything, it keep giving a black screen forever

The nomodeset parameter disables Mode-Setting on graphics. It can result in poor graphics quality or failing to initialize Graphics Drivers even (or it can fix them)... But I cannot think of a way that it prevents Boot or Grub Menu.
Modesetting occurs after passing the drivers off. Which means you should be past boot and grub and reaching the desktop Login before that even becomes relevant.

Can you please ensure that during reboot, you are tapping esc or tab key vigorously?

Was GRUB_TIMEOUT_STYLE set to hidden?
Was GRUB_TIMEOUT set to 0?

Okay, I will try now and let you know

to answer your question
Was GRUB_TIMEOUT_STYLE set to hidden ? -> YES
Was GRUB_TIMEOUT set to 0 ? -> it is set to 100

10 (seconds) should be sufficient but a hundred seconds works, too...:stuck_out_tongue:
Too many users read guides that suggest setting that value to zero - and this later means they cannot get to Grub Menu when they need to.

Grub Timeout Style = Hidden means that the Grub Menu is hidden from view unless actively called upon.
Setting this to "menu" instead of "hidden" means that the menu will be shown at every restart.

In order to affect any changes... really need to access the Grub Menu here.

Thank you, I was able to ssh the machine hopefully

Here is my grub file config
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

update-grub result:

x@x-desktop:~$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/zorin/theme.txt
Found linux image: /boot/vmlinuz-5.15.0-46-generic
Found initrd image: /boot/initrd.img-5.15.0-46-generic
Found linux image: /boot/vmlinuz-5.13.0-35-generic
Found initrd image: /boot/initrd.img-5.13.0-35-generic
Found linux image: /boot/vmlinuz-5.11.0-44-generic
Found initrd image: /boot/initrd.img-5.11.0-44-generic
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
Adding boot menu entry for UEFI Firmware Settings
done

for the grub-probe error I have entered:

sudo grub-mkdevicemap

sudo update-grub

But I'm still getting black screen

Every one of your settings looks good.

The Intel Iris... and the XE Graphics... they come up a lot. And while sometimes a parameter change (Like we tried above) works... A lot of the time...
A Fresh Reinstall of the Distro is what solves the issue.

If you dread reinstalling Zorin OS... then the only other recommendation I can offer is trying a different Kernel.
But... the 5.15.0-53 current kernel really should just work. I have my doubts that switching the kernel would do the trick. The best chance would be in rolling back to an earlier kernel.
If this was me... I would opt to redownload Zorin OS and check the integrity of the download. Then reburn to USB Stick and reinstall.
Changing the kernel means changing your DKMS and setting the kernel to default boot to the working one instead of the newest one after there is a system Upgrade.
And if Reinstall does the trick, that makes it the better option.

Thank you, I'm ok to reinstall the OS however there is no F2 or F8 or F12 when I boot the machine, nothing, I can't access these at all, I tried ESC, FN+F2 F7 F8 F11 F12 ... nothing

Can I plug in the USB and from VNC Desktop I click to install?

That is very odd.
What is the make and model and BIOS version of the machine?

I don't recall the model but it's an Intel Nuc built by Aleutia.

I did a test, I upgraded the kernel, previous kernel was 5.15.0-46-generic, after dist-upgrade the kernel is 5.15.0.53, I have a second identical machine model running the same kernel and it's fine running Zorin 16 pro 16.2

I don't know what could still be the issue

try replacing the hdmi cable, that can cause display detection issues, no video issues, or intermittent display issues

Guys I was able to get to the bios using this command

systemctl reboot --firmware-setup

then I activated boot USB first in priority and I'm now installing Zorin from scratch

2 Likes