Issue with dual booting os on mbr drive

Good day everyone,
So I'm trying to dual boot zorin os alongside windows 10, I tried the manual partitioning approach (I have about 100gb unallocated space). The first issue I observed was that after I created a partition for home (about 50gb). It got created but the remaining unallocated space was termed unusable.
The drive I'm using is an mbr which from the research I've done isn't supported, Bios is on legacy mode.
My question now is that is it possible for me to dual boot with mbr(I don't want to change to gpt due to risk of data loss) and bios in legacy mode?

I also tried to follow along with the post on partitioning and installing zorin os, I got an error, something around the likes of unable to create more than 4 primary partitions.

Recommendations please

MBR only allows for up to Four Partitions. How many partitions does your drive have?

My drive has 3 partitions.

Have you run a S.M.A.R.T. test on the drive to determine if any corruption, bad blocks or bad sectors are involved?

Is that 3 partitions before creating the 50 Gb partition? If not, that is why the last one is unusable. MBR restricts usage to four partitions and cannot be circumvented by using a second drive.

Try making your installer with Unetbootin - that will allow a legacy type install. I've tried recreating the install scheme from a 'auto' legacy install on my own but always miss something or don't flag something; I'm sure there are lots of 'how-to's' out on it - just never got it working manually set-up. I'll try to find the best one out there and post back. Just a few extra steps - but you will need a /boot directory..

Check this out:

Starting at 'Step 6' - that should get you in the right direction. LVM stuff, up to you - that's drive encryption. Not sure why it's chosen on the guide but you do not need it for installing.. Also /boot can be ~512MB, you won't need a full out 1GB for holding boot files; 512MB matches the UEFI scheme - have not seen any of even my dual-boot machines use more than about 70MB total. I'm sure others will chime in to say they need more - but matching UEFI size would be best.

Thanks a whole lot for the effort , I eventually installed it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.