Issue with game, graphics capability

Hi all,

I just installed Zorin 16 and Steam.

I am playing only one game, Football manager 2021.

In other distros ( especially Arch based ) I dont have any issues and
the game setup told me that my PC graphics capability is high or full stars. But on Zorin I got only one star, and everything is so slow and laggy. Screenshot from 2021-08-19 00-00-42

Why it is like this ? Am I missing some driver or what ?

AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx



Try upgrade the Open Source driver;

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update && sudo apt -y upgrade
1 Like

Or if using Zorin OS 16,

sudo add-apt-repository ppa:ubuntu-x-swat/updates

instead of the oibaf ppa which is for Zorin OS 15.

I tried this, but nothing is updated.. only update-notifier ( which is not driver xd )

Can you open Software & Updates app and move to the additional drivers tab.
Relay (Or screenshot) what is listed.

Screenshot from 2021-08-19 10-28-51

Ok, a couple of options then... can try a grub parameter:

sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="--verbose nouveau.noaccel=1"

Reboot and test.

If that does not work, in terminal create a new file:

sudo nano /etc/X11/xorg.conf.d/1-amdgpu.conf

Paste into it:
Section "OutputClass" Identifier "AMDgpu" MatchDriver "amdgpu" Driver "modesetting" #Option "PrimaryGPU" "No"

Hit ctrl+x to exit, the y key to say yes to save and then the enter key to save as current config - reboot and test.

1 Like

first option didnt change anything.

second one ,got error : Error writing /etc/X11/xorg.conf.d/1-amdgpu.conf: No such file or directory ]

Does it have something with Vulkan? On arch I used AMDVLK

I typoed. sorry...

sudo nano /etc/X11/xorg.conf.d/10-amdgpu.conf

If it gives that error again, elevate your file manager to root and use your file manager and text editor with elevated permissions to create the file graphically.

That would be the xswat repo posted above.

sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils

1 Like

in X11 folder I dont have xorg.conf.d and the rest. Should I manually add them ?

Also I installed vulkan drivers, still nothing was changed in the game..I dont know what is responsible for that.. and what is the main difference between Arch and Ubuntu. :confused:

Do you have xserver-xorg installed?

Arch is Rolling release and Ubuntu is Stable release. Arch requires a lot of know-how and the forums are... not as ... diplomatic or patient as this one.

1 Like

I am not sure about xserver-xorg. I am beginner with Ubuntu :slight_smile:

On Arch, Manjaro distro I never needed to install additional things. It was plug and play :slight_smile:

It's as much luck as design... I have never needed to install the essentials using Zorin OS on any computer here... But I see others that need to. The same is true on either the Arch or Manjaro forums, where occasionally, someone needs to install a different package to get things working.

No harm in trying, I guess:

sudo apt install -y xserver-xorg

sudo apt install -y xserver-xorg-input-all

It is already installed :slight_smile:

Yeah, maybe I am unlucky one. I tried different distros, also different DE.
Also I figured that I got weird results with xfce, kde and gnome.
For example Gnome and KDE gave me most "stars".

And on Elementary os I am not able to run my game or steam.

I really like Zorin, also thought about buying Pro version, that is why I first installed core to check if everything is ok

Had you tried POP_OS?
And on Arch, it works with more stars showing for graphics capability?

I tried POP_OS yes, but I prefer Zorin. I always prefer to support smaller projects :slight_smile:
On arch I have 3-4 stars from 5, sometimes even 5/5

I was just asking if it worked on POP_OS

ah sorry :stuck_out_tongue:

Yes, it worked there

Those drivers would be in the kernel. Hmmm... I don't suppose you remember what kernel you were running on them, do you?