Issues mounting HDD ExFat between 2 Zorin Accounts

Dear All,

I'm having issues on making a second HDD work between 2 Zorin accounts, one is a limited account I use for daily use, another Administrator status only to change system parameters and install some apps.

Well, I have used the "Disks" app to mount the HDD, which is formatted to ExFAT instead of NTFS, because ExFAT is more compatible, if I login to my main account, I can't get access to the ExFAT HDD on my Administrator account, the same happens otherwise, it seems the first account that mounts the second HDD, gets hold of it, and won't let go, unless I reboot the system, which is weird.

On the mounting options, I have added these parameters.

gid=1000,uid=1000,nodev,nofail,x-gvfs-show,nobootwait

Also is worth noting, when booting, the second HDD doesn't automatically mounts, unless I boot the "Files" app, which is another thing weird.

Is there a solution to this issue?

Thanks

Remove the uid since you want the mount accessible by all users in that group. Make sure the "other" user is a part of the same group as the one that made the mount. If it is automatically mounted at boot you may have to remove this setting in order to give everyone access.

337harvey,

Thanks, added the group sudo to my limited account, it can now mount HDD, but it doesn't auto mount whenever the computer boots. However when I go to my administrator account, since HDD was mounted on the other account, still can't get access to it, as per image

This is so weird

What are you attempting to open? All files are application specific. Some to the generality of text or image, some are extremely specific (pdf, archive, etc) and will require specific software. I say all this because the error given is for unknown file type.

Have you checked the disk for errors? This could be a sign of a failing drive. How old is it?

In the /etc/group file you should be able to check what groups both users are affiliated with and what gid to use to ensure access.

You can auto-mount the drive at boot, but you will have to create an entry in the /etc/fstab with the proper gid.

Thanks again for your reply, the HDD is brand new, is only a week old, actually I use dual boot and on Windows I have zero issues, also another distro, mint, never had any issues either, I guess is something in Zorin.

I selected defaults settings on "Disks" apps, only added the option nobootwait to mount on boot, and now I get this error, the error depends on the parameters on the mounting

This may help.

Thanks , going to study that explanation

Already found an easier way to fix this issue, firstly ran

lsblk

to see the available partitions, and then created a startup application, with udisksctl, which forces mounting, and now whenever the computer boots I have the HDD available :grinning:

udisksctl mount -b /dev/sdb1

Now I have a fully working Zorin with no issues, this distro is so beautiful and modern.

1 Like